Bug 1061609 - InitialContext swallows original exception cause
Summary: InitialContext swallows original exception cause
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Naming
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: DR0
: EAP 6.3.0
Assignee: Carlo de Wolf
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1061631
TreeView+ depends on / blocked
 
Reported: 2014-02-05 08:14 UTC by Carlo de Wolf
Modified: 2014-06-28 15:30 UTC (History)
4 users (show)

(edit)
In previous versions of EAP 6, instantiation of an InitialContext might fail with the following message:
----
javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory com.sun.jndi.ldap.LdapCtxFactory from classloader ModuleClassLoader for Module "deployment.externalContextBindingTest.jar:main" from Service Module Loader
----

From this message, however, the underlying cause was not visible, making troubleshooting impossible. To resolve this issue, the underlying cause has now been exposed. If this issue now occurs, the error message now reveals the root cause:

----
javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory com.sun.jndi.ldap.LdapCtxFactory from classloader ModuleClassLoader for Module "deployment.externalContextBindingTest.jar:main" from Service Module Loader [Root exception is javax.naming.CommunicationException: 127.0.0.1:10389 [Root exception is java.net.ConnectException: Connection refused]]
----
Clone Of:
: 1061631 (view as bug list)
(edit)
Last Closed: 2014-06-28 15:30:35 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2868 Critical Resolved Expose underlying cause during InitialContextFactory instantiation 2015-07-14 14:35:24 UTC

Description Carlo de Wolf 2014-02-05 08:14:50 UTC
Instantiation an InitialContext might fail with just the follow cause:
javax.naming.NamingException: JBAS011843: Failed instantiate InitialContextFactory com.sun.jndi.ldap.LdapCtxFactory from classloader ModuleClassLoader for Module "deployment.externalContextBindingTest.jar:main" from Service Module Loader

The underlying cause is no longer available.

Comment 4 Jan Martiska 2014-02-21 12:23:08 UTC
Verified in 6.3.0.DR0.

Comment 5 Scott Mumford 2014-04-24 04:01:07 UTC
Included release note from bug 1061631 (duplicate) written for EAP 6.2.1 Release Notes.

Marking for inclusion in documentation.

Comment 6 sgilda 2014-05-12 19:58:57 UTC
Changed <screen></screen> tags in Doc Text to ticks (`) to fix Bug 1096865


Note You need to log in before you can comment on or make changes to this bug.