Bug 106175 - gdm fails first login attempt when home directory is not mounted (with autofs)
Summary: gdm fails first login attempt when home directory is not mounted (with autofs)
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-03 14:20 UTC by Mikko Paananen
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-03 00:09:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mikko Paananen 2003-10-03 14:20:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030822
Mozilla Firebird/0.6.1

Description of problem:
My home directory is on server, shared with NFS. On client workstation /home
uses automounter (autofs) and mounts automatically home directories from server
when they're used.

However, after boot or after mount is unused and expired (unmounted), any login
attempt with gdm fails popping up a window stating "... session took less than
10 seconds. etc ..."

.xsession-errors contains only two lines:
/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/bin/X11/sessreg -a -w
/var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l :0 mikko

When first attempt fails, home directory gets mounted somewhere in progress and
second attempt succeeds. Login on console works fine.


Version-Release number of selected component (if applicable):
gdm-2.4.4.0-2

How reproducible:
Always

Steps to Reproduce:
1. Boot
2. Try to log in using gdm => failure
3. Try again => works


Actual Results:  First login attempt fails.


Expected Results:  Home directory should be mounted and login succeed.


Additional info:

/etc/auto.home:

*       utopia:/export/home/&

automount is up and running. Server is RH7.3 and it's IP is listed in /etc/hosts.

The same setup used to work on RH9.

The problem started during Severn beta1, I can't remember if it was after
upgrade to Gnome 2.4 or with installation of beta1.

Comment 1 Mikko Paananen 2004-02-03 00:09:15 UTC
*Shamed*

It seems that this is a not bug after all, but a interaction of
keychain-script and gdm started ssh-agent. Keychain was killing the
other copy of ssh-agent that was started by gdm, causing X session to
terminate prematurely.

This didn't happen in previous versions of Redhat Linux since those
didn't start ssh-agent from gdm as Fedora 1 does.



Note You need to log in before you can comment on or make changes to this bug.