Bug 106211 - exclude list being ignored.
exclude list being ignored.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pcmcia-cs (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-03 13:08 EDT by Dave Jones
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-28 12:05:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2003-10-03 13:08:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030908
Galeon/1.3.9

Description of problem:
Radeon IGP chipsets are having machine check exceptions happen
as soon as PCMCIA starts up. The reason for this is that its poking
the reserved areas (0x380-0x3ff) even though it shouldn't be, and is marked
clearly in the config.

Changing the include line from..
include port 0x100-0x4ff, port 0xc00-0xcff
to
include port 0x100-0x379, port 0x400-0x4ff, port 0xc00-0xcff

(Ie, doing the exclude by hand) confirms that this is the problem.

Additionally, the range is too wide. It should exclude 0x3b0 -> 0x3bb
and 0x3b3->0x3b3.  This aparently is the reason why we are having problems with
Sony VAIO laptops & their CD drives.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. boot on RadeonIGP system
2. Start PCMCIA
3.
    

Actual Results:  Fatal MCE

Expected Results:  Boots correctly.



Additional info:
Comment 1 Bill Nottingham 2003-10-03 15:53:34 EDT
<davej> should be 3d3

(not 3b3)
Comment 2 Michael K. Johnson 2003-10-21 16:28:57 EDT
Dave, do we need to build a new kernel-pcmcia-cs?
Comment 3 Dave Jones 2003-10-21 16:58:58 EDT
I think Bill already did, though I've not confirmed this since.
I'll look into it.
Comment 4 Chris Ricker 2003-10-21 18:34:48 EDT
Bug #104320 also says that a kernel-pcmcia-cs update will fix the bug, but there
hasn't been any update....
Comment 5 Dave Jones 2003-10-28 12:05:23 EST
Confirmed, the exclude list is now being honoured with the default config
with the current pcmcia-cs package.
No more MCEs...
Comment 6 Chris Ricker 2003-10-30 01:26:22 EST
I still hang if the internal NIC is plugged in at boot-up, which Bug #104320
says is fixed by this exclude list

kernel-2.4.22-1.2110.nptl
kernel-pcmcia-cs-3.1.31-13

reopen? something else?
Comment 7 Dave Jones 2003-11-20 14:23:25 EST
likely something else.

Note You need to log in before you can comment on or make changes to this bug.