Bug 106247 - Previewing WAV file with nautilus-media locks hard
Previewing WAV file with nautilus-media locks hard
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-03 19:44 EDT by Paul W. Frields
Modified: 2015-01-04 17:03 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-07 00:35:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2003-10-03 19:44:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
If I abort a preview of a WAV file -- RIFF little-endian, PCM, if it matters --
mid-stream, and then try and preview any WAV file (whether the same file or
not), the system locks up. CapsLock+ScrollLock flash, and no user input is
accepted, including mouse, virtual terminal change key sequences, and SysRq. The
system must be manually restarted. Sometimes (depending on the length of the WAV
apparently) the WAV file will play endlessly in a loop until the system is reset
by hand. I believe all the files I tried were 16-bit, some 22kHz and some 44kHz.

Version-Release number of selected component (if applicable):
nautilus-media-0.3.1-1

How reproducible:
Always

Steps to Reproduce:
1. Hover mouse pointer over a WAV file in Nautilus browser in order to hear preview.
2. Abort the preview mid-stream, by moving mouse off the file icon.
3. Hover mouse pointer over any WAV file, the same one or a different one.
    

Actual Results:  The system locks hard, requiring a manual reset or power cycle.

Expected Results:  The preview should have stopped, and the second preview
should start normally without anomalies.

Additional info:

Fedora Core test2, have upgraded to nautilus 2.4.0-4 from rawhide. Other
possibly related culprits' versions on my system:

gstreamer-0.6.3-1
gstreamer-plugins-0.6.3-3

I am not sure that nautilus-media is the exact place to file this bug; I took my
best guess.
Comment 1 Paul W. Frields 2003-10-03 19:55:06 EDT
Possibly related bug?

http://bugzilla.gnome.org/show_bug.cgi?id=120202
Comment 2 Bill Nottingham 2003-10-03 23:34:48 EDT
If capslock and scrolllock are flashing, your kernel is oopsing.
Comment 3 Paul W. Frields 2003-10-04 00:20:09 EDT
Just an FYI, same behavior under 2.4.22-1.2082.nptl from rawhide.
Comment 4 Paul W. Frields 2003-10-09 17:28:48 EDT
Behavior the same under kernel-2.4.22-1.2087.nptl from rawhide. All rawhide
updates in place as of this writing (except fedora-release). This is an Athlon
T-bird 1.4GHz, KT133A (Iwill KK266+) mobo, CMI8738 (13f6/0111) sound, FWIW.

Can I provide something more helpful to help chase this down? I am not a kernel
hacker, but I am RHCE and willing to help if someone will shove me in the right
direction with a map and flashlight.
Comment 5 E Chion 2003-10-14 10:29:36 EDT
Just a quick "breaks for me too" comment.  Would love this fixed as it's pretty
easy to trip oneself up with this kind of problem.
Comment 6 Paul W. Frields 2003-11-21 08:21:58 EST
More information available now. This problem has persisted into Fedora
Core 1 (kernel-2.4.22-1.2115.nptl), but appears to be hardware
specific and perhaps should be moved to the kernel component. 

The problem does *NOT* occur on the following hardware that I had
available for FC1 installs:

- i815 based laptop (Gateway Solo 9500), ESS Maestro ES1988 sound
- VIA KT400 (Soyo Dragon Ultra) desktop, VIA 8233/A/8235 AC97 sound

Nevertheless, the KT133a/CMI8738 is common enough (and of an
appropriate vintage) that this bug should be addressed.
Comment 7 Paul W. Frields 2003-11-21 08:22:26 EST
Oops, it is in kernel. Sorry about that.
Comment 8 Dave Jones 2003-11-21 10:42:05 EST
I think I've fixed this. It'll be in the forthcoming errata.
Comment 9 Paul W. Frields 2004-02-07 00:35:05 EST
It is indeed. Thank you, sir! I'm very late on closing this bug, but
certainly it's been fixed since at least before 2.4.22-1.2138.nptl,
and probably much earlier.

Note You need to log in before you can comment on or make changes to this bug.