Bug 106258 - Media check fails, because of read errors?
Summary: Media check fails, because of read errors?
Status: CLOSED DUPLICATE of bug 107280
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-04 09:17 UTC by Behdad Esfahbod
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Behdad Esfahbod 2003-10-04 09:17:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/1.0

Description of problem:
I guess this is not an anaconda issue, but don't know the relevant module.

Well, I burned my isos with correct MD5 on good brand CDs, and started
installing, all with my new laptop.  I got media check failure for two of the
CDs, retried and again failed.  But proceeded to install, and all the problem I
had was two or three times I was told that some file cannot be read, and
choosing retry solved the problem.  So is seems that it's more a minor CD read
problem, that does not harm.

Can media check have any paranoid mode that tries to overcome this problem? 
Perhaps by forcing to read each sector twice??  Or doing retries if it detects
an error?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Don't know.
2.
3.
    

Actual Results:  media check failed.

Expected Results:  media check passed.

Additional info:

Comment 1 Fulton Green 2003-10-05 04:43:48 UTC
I've seen a few other comments on the listserv to this effect, and I have
personally noticed that, at the very least, disc 1 of test2 fails the test2
mediacheck.  HOWEVER ... all three discs PASS the TEST1 (the pre-Fedora beta)
mediacheck, and disc 1 of test1 FAILS in the TEST2 mediacheck.  So I'm inclined
to lay the blame on the test2 mediacheck.

Comment 2 Michael Fulbright 2003-10-09 16:22:59 UTC
This may be related to kernel issues in test2.

Let us know if the next test release behaves better.

Comment 3 Fulton Green 2003-10-14 13:45:50 UTC
Unfortunately, test3 still shows the same behavior.  My test3 disc1 CD fails a
self-mediacheck, but passes the test1 mediacheck.

Maybe it's time for a separate test1-based "mediacheck image"? ;-)

Someone with the proper permissions needs to change this to a test3 bug.

Comment 4 Jeremy Katz 2003-10-16 18:43:49 UTC
Can you try adding 'ide=nodma' to your boot command line and see if it makes
things better?

Comment 5 Fulton Green 2003-10-23 12:41:02 UTC
That fixed it.  At least with disc 1 of test3, which was the only one I bothered
to check. :)  So before closing this issue out, it might be good to decide one
of of at least three options:

- should the "mediacheck" kernel boot parm also infer the "ide=nodma" parm?
- or should the mediacheck FAIL screen mention retrying with ide=nodma?
- or is the current plan to fix the DMA issue?

Thanks again for the fix.

Comment 6 Jeremy Katz 2003-10-23 16:35:38 UTC

*** This bug has been marked as a duplicate of 107280 ***

Comment 7 Red Hat Bugzilla 2006-02-21 18:58:55 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.