Bug 107280 - using DMA for cd-rom drives during install
using DMA for cd-rom drives during install
Status: CLOSED DUPLICATE of bug 109462
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 106258 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-16 10:28 EDT by Dennis Björklund
Modified: 2015-01-04 17:03 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Björklund 2003-10-16 10:28:34 EDT
Fedora turns on dma on my old 32x cdrom during install and then it fails,
something rh9 did not do. Should it really use dma for cd-roms since there are a
lot of broken devices out there. Especially during install it's important that
it works.

I got the install to work after giving the kernel parameter ide=nodma. If dma is
something we want as default maybe it could be good to add some doc about
ide=nodma on the kernel help screen.
Comment 1 Dave Jones 2003-10-21 21:26:07 EDT
It would be good to blacklist drives which can't do DMA.
What does hdparm -i say about your drive ?
Additionally, we probably should say something in the release notes if we decide
to keep this feature.
Comment 7 Alexandre Oliva 2003-10-22 14:23:02 EDT
Isn't this a dup of bug 106685?  Or does the problem occur at install time, not
check time?
Comment 9 Jeremy Katz 2003-10-23 12:35:40 EDT
*** Bug 106258 has been marked as a duplicate of this bug. ***
Comment 10 Dennis Björklund 2003-10-23 12:46:00 EDT
In my case I can't read any cd-roms when dma is turned on. I've tried with both
burned cdr's and normal cd-roms and it just gives a lot of errors in my log file.

It's not a computer that I normally use. I'll come back with more data about the
exact cd-rom models. I remember that it is a Intel 440BX computer (ABit BE6 I
think), it's got a samsung 32x cdrom drive model 3232 and a mitsumu cd-burner
(2X). Pretty old stuf, but still usable.

Neither the burner nor the cdrom drive can read any discs (without lots of
errors) when dma is turned on. With it turned off both worked fine.
Comment 11 Jeremy Katz 2003-10-24 15:14:14 EDT
anaconda now turns off DMA on all IDE CD-ROM devices (unless you pass a command
line parameter) to avoid this causing problems for the install.

It could still be problematic post-install, though.
Comment 12 Dave Jones 2003-11-20 13:17:00 EST

*** This bug has been marked as a duplicate of 109462 ***
Comment 13 Red Hat Bugzilla 2006-02-21 13:59:13 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.