This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 106282 - ldap started past autofs
ldap started past autofs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: openldap (Show other bugs)
RC3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 16:06 EDT by Olaf Segger
Modified: 2014-08-31 19:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: openldap-2_2_23-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-01-11 12:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Olaf Segger 2003-10-04 16:06:23 EDT
Description of problem:
In the boot process ldap is started when autofs is already running.
This is a problem since I have stored the auto.master map in ldap, but on the
ldap server the automounter does not find this map since ldap is not running at
the time this map is needed. Please look at Bug #97417.

Version-Release number of selected component (if applicable):
openldap-servers-2.1.22-3,autofs-3.1.7-40

How reproducible:
Always

Steps to Reproduce:
1. Put the auto.master map in ldap
2. reboot the ldap server machine
    
Actual results:
The mountpoints in the ldap auto.master are not mounted.

Expected results:
One can use the automount mountpoints given in the ldap
auto.master

Additional info:
Please look at Bug #97417.
The problem is, that autofs starts mit S28autofs, openldap-server with S39ldap.
Possible solution: start openldap-server with S27ldap like ypserv please
Comment 1 Stephen Walton 2005-05-13 17:27:58 EDT
This is a dupe of bug 67753.
Comment 2 Jay Fenlason 2006-01-11 12:03:49 EST
According to the CVS changelogs, this was fixed for FC4 

Note You need to log in before you can comment on or make changes to this bug.