Bug 106283 - GConf2 needs a newer version of ORBit2 than automatically detected
GConf2 needs a newer version of ORBit2 than automatically detected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: GConf2 (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
: Triaged
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-04 16:40 EDT by Göran Uddeborg
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-15 06:00:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2003-10-04 16:40:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Installing GConf2-2.4.0-1 on a system with an older version of ORBit2 succeeds.
 All dependencies RPM knows about are fulfilled.  But when trying to run
gconfd-2 it crashes because the symbol ORBit_skel_class_register can not be
resolved.

Version-Release number of selected component (if applicable):
GConf2-2.4.0-1

How reproducible:
Always

Steps to Reproduce:
1. Install ORBit2-2.5.1-1
2. Install GConf2-2.4.0-1
3. Try to run /usr/libexec/gconfd-2
    

Actual Results:  It just terminates, since gconfd-2 first rebinds stderr to
/dev/null.  But with a trace, one can see this message:

writev(2, [{"/usr/libexec/gconfd-2", 21}, {": ", 2}, {"relocation error", 16},
{": ", 2}, {"/usr/lib/libgconf-2.so.4", 24}, {": ", 2}, {"undefined symbol:
ORBit_skel_class_register", 43}, {"", 0}, {"", 0}, {"\n", 1}], 10) = 111

Expected Results:  gconfd-2 ought to run.

Additional info:

The GConf2 RPM needs an explicit "Requires: ORBit >= X.Y.Z".  I don't know the
exact minimum for X.Y.Z.  2.5.1 is too low, while 2.8.0 is high enough.  Is it
easy to see somewhere when ORBit_skel_class_register was added?
Comment 1 Warren Togami 2004-04-11 05:02:54 EDT
Removing EasyFix.  EasyFix may be re-added if someone finds the exact
X.Y.Z so this is a trivial matter for the package maintainer.
Comment 2 Göran Uddeborg 2004-04-13 05:31:07 EDT
An easy fix would be to actually require 2.8.0.  It might be overly
conservative, but it would work.
Comment 3 Warren Togami 2004-04-15 06:00:56 EDT
rawhide soon

Note You need to log in before you can comment on or make changes to this bug.