Bug 106285 - The replies Y/N/C in functions are marked for translation but not extracted
The replies Y/N/C in functions are marked for translation but not extracted
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-04 17:34 EDT by Göran Uddeborg
Modified: 2014-03-16 22:39 EDT (History)
3 users (show)

See Also:
Fixed In Version: 7.47-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-17 01:01:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Look for all $"... strings, not only after special prefixes (1.37 KB, patch)
2004-03-02 11:02 EST, Miloslav Trmac
no flags Details | Diff

  None (edit)
Description Göran Uddeborg 2003-10-04 17:34:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The problem is the same as in bug 73251, but the reason is different, so I open
a new case.  The script po/xgettext_sh.py will not extract the reply strings
like "yY" from init.d/functions.

Version-Release number of selected component (if applicable):
initscripts-7.34-1

How reproducible:
Always

Steps to Reproduce:
1. Inspect initscripts.pot

Actual Results:  There is no string "yY" to translate.

Expected Results:  It should be there.

Additional info:

The problem now is that none of the tokens in i18n_tokens appear on the line
where these strings are.  Maybe "strstr" should be added in i18n_tokens?
Comment 1 Miloslav Trmac 2003-10-05 11:35:47 EDT
Wild guess: is the initscripts package on the machine where
(make -C po new-pot-file-i-really-mean-it) is run current enough?
Comment 2 Bill Nottingham 2003-10-06 01:38:27 EDT
No, it's that it's not caught by the extractor script.
Comment 3 Miloslav Trmac 2004-03-02 11:02:28 EST
Created attachment 98195 [details]
Look for all $"... strings, not only after special prefixes

The attached patch removes the '$" is accepted only after specific prefixes'
limitation from the extractor scripts, finding many more marked strings
than the previous one.
Comment 4 Bill Nottingham 2004-03-17 01:01:54 EST
Added in 7.47-1, thanks!

Note You need to log in before you can comment on or make changes to this bug.