Bug 106292 - gnome-icon-theme only has 48x48 apps/redhat-* icons
gnome-icon-theme only has 48x48 apps/redhat-* icons
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-icon-theme (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-04 22:27 EDT by Justin Georgeson
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 07:36:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Georgeson 2003-10-04 22:27:47 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Upon changing the default inherited icon theme from Bluecurve to gnome, I
discovered that the RedHat apps icons (for all the categories on the menu) are
only there in size 48x48. Since the menu uses the smaller icons, half the group
items in the menu don't have icons.

Version-Release number of selected component (if applicable):
1.0.6-1

How reproducible:
Always

Steps to Reproduce:
1. Edit /usr/share/themes/default/index.theme, change "Inherits=Bluecurve" to
"Inherits=gnome".
2. View the main menu (Alt-F1)


Actual Results:  All the program groups should have icons

Expected Results:  The Games, Graphics, Internet, Programming, Sound & Video,
System Tools, and several of the More <category> groups don't have icons
    

Additional info:
Comment 1 Mark Finlay 2003-10-05 03:47:04 EDT
I was about to add this bug, because I was one of the people in gnome involved
in updating the menu icon in the icon theme for gnome 2.4, and so was very
dissapointed to see that they are not in the redhat menus.

This breaks every icon theme in gnome except bluecurve and so should be
concidered a major issue.
Comment 2 Mark Finlay 2003-10-07 03:56:13 EDT
Also this bug is not infact a problem in gnome-icon theme because it effects all
themes except blucurve so it must be a bug in bluecurve/redhat gnome patches.
Comment 3 Justin Georgeson 2003-10-07 10:39:37 EDT
Well, I suspect that in a gnome.org installation, there is a
/usr/share/icons/default which just says to inherit from the gnome theme. RedHat
says to inherit from the bluecurve theme. The menu groups configured by redhat
all use redhat-*.png icons. So in order to still have icons for those groups
when you install a theme inheriting from the gnome theme, you have to have those
same icon names in the gnome theme. In RH 9 they are just symlinks to icons in
/usr/share/pixmaps, I think. So depending on your point of view, the bug is
either that the icons are missing from the gnome theme, or that the menus are
configured using nonstandard icons. I really like RedHat's menu config though,
so I consider the bug to be in the gnome-icon-theme package. ;)
Comment 4 Alexander Larsson 2003-10-07 11:28:17 EDT
I'm not sure what /usr/share/icons/default is, or what uses it, but the problem
is that the icons used by the redhat menus uses various icons from all over the
place. Some of them are only in the bluecurve icon theme. 

However, just renaming the icons used in the redhat menus to match the
gnome-icon-theme icon names isn't really right either. The menus are used from
KDE too, and just using gnome names means all kde icon themes will be broken.

Whats really needed is coordination of the common icon namespace that the
desktop shares. In this sense the common icon theme spec is just a horrible
failure. Icon themes aren't really common at all, it just sort of looks like it.
Comment 5 Justin Georgeson 2003-10-07 11:43:30 EDT
Yeah, what he said. :) /usr/share/icons/default/ just has an index.theme which
declares Inherits=Bluecurve. Bluecurve specifies redhat-email.png for the
Evolution launcher, so switching to a theme without a redhat-email.png suddenly
has no Evolution icon. So the default says to inherit from Bluecurve, and
everything is Ok. I prefer the gnome icons, as they are app specific, personal
pref. Since the gnome icon theme is included too, it was packaged with some
overlap. to continue the evolution example, the gnome icon theme had
redhat-email.png, I think just symlinked to /usr/share/pixmaps/evolution.png. So
using the gnome theme all the RH menu items still had an icon. The latest beta
has this for 48x48 icons, but nothing else. The panel now lets me specify a
specific pixel size, so I think it just scales the 48x48, so that works fine.
But the menu seems to be looking specifically for 24x24 icons, which aren't
there. I could test my guess if I knew how to make the menu use 48x48 icons. The
intended effect is that for any icon theme which does not specify an icon for a
particular group/app, it will use the Bluecurve one. I have had varying success
setting the Inherits here to gnome, and specifying it explicitly in per icon
theme. I've seen some themes (AquaFusion, at art.gnome.org) not use its own
icons, instead grabbing some from the inherits. This usually ends up being an
app/group using a redhat- style icon (Evolution is the first thing that comes to
mind). The intended effect is that for any icon theme which does not specify an
icon for a particular group/app, it will use the Bluecurve one. I have had
varying success setting the Inherits here to gnome, and specifying it explicitly
in per icon theme. I've seen some themes (AquaFusion, at art.gnome.org) not use
its own icons, instead grabbing some from the inherits. This usually ends up
being an app/group using a redhat- style icon (Evolution is the first thing that
comes to mind). 
Comment 6 Justin Georgeson 2003-10-07 11:46:51 EDT
that post was about twice as long as it should have been. Everything after "The
intended effect" should have been deleted. Sorry about that.
Comment 7 Mark Finlay 2003-10-07 13:43:28 EDT
To me the simplest way to make it work would be to make bluecurve conform to
either the way gnome or kde does it and then provide system links to make it
work with the other one. That way we/you could take out the patches from Gnome
that are breaking all the other icon themes.
Comment 8 Alexander Larsson 2003-10-08 05:55:19 EDT
I don't understand what you mean. Say we change the icon for the accessories
menu item from "redhat-accessories" to "gnome-util". This means themes with
"gnome-util" in them (i.e. themes designed for gnome) will show an icon. But if
you're running KDE and selected a kde icon theme its not gonna have "gnome-util"
in it. How would you add a symlink to fix that?

I guess what we could do is add the redhat specific icons to the "hicolor"
theme, since that is the location for common default icons (such as application
icons). "hicolor" is really the only common namespace KDE and Gnome share.

Its a bit busted that the panel doesn't seem to scale icons. It should do that.
Comment 9 Justin Georgeson 2003-10-08 10:57:05 EDT
I agree that a solution which addresses both desktops is ideal. I guess I don't
understand what is so broken. I don't think I ever tried KDE in RH9 or FC, but
'gnome' icon theme had enough icons to where making it the default instead of
Bluecurve worked. I would assume the KDE equivalent of the 'gnome' theme was
similarly updated. Why not just diff the packages to find the missing icons?
What was wrong with symlinking the official GNOME/KDE icons to the equivalent
redhat- icons?

The panel seems to be scaling icons correctly for me. I haven't installed any
updates except for kernels I downloaded manually (can't seem to get apt to pick
up rawhide updates from freshrpms).
Comment 10 Alexander Larsson 2003-10-08 11:39:46 EDT
justin: You can't "Why not just diff the packages to find the missing icons?". A
KDE icon theme and a Gnome icon theme contain completely different icons. The
bluecurve icon theme has *both* the icons from Gnome and from KDE.
Comment 11 Justin Georgeson 2003-10-08 13:26:11 EDT
I realize that. What I had meant was diff gnome-icon-theme-1.0.0-4 from RH9 with
gnome-icon-theme-1.0.6-1 from FC to see what icons were removed, and put them
back in. Likewise for the KDE equivalent. But I just downloaded the RH9 package
and realise I have been using a flawed assumption. The gnome icon theme package
from RH9 also only has 48x48 equivalents of the Bluecurve icons. 

So I've done a little more digging, and it turns out that the files pointed to
by the symlinks in /usr/share/icons/gnome/48x48/apps (redhat-games.png,
redhat-graphics.png, redhat-internet.png, redhat-programming.png,
redhat-sound_video.png, and redhat-system_tools.png) were missing. Turns out
they were included in gnome-desktop in RH 9 but are not included in
gnome-desktop in FC. So, restoring those missing pixmaps (gnome-joystick.png,
gnome-graphics.png, gnome-globe.png, gnome-devel.png, gnome-multimedia.png, and
gnome-system.png) fixes this problem for GNOME. (I populated them with
placeholders to verify, but could only check via nautilus pointed to
'applications:///' as I'm not at home right now)

Sorry I didn't dig deep enough before filing this report.
Comment 12 Mark Finlay 2003-10-08 14:41:28 EDT
alex: What I meant is that you let gnome use gnome specific icon themes and kde
use kde specific icon themes and have bluecurve be modified to support both -
instead of modifying/breaking Gnome so that it supports the way the bluecurve works.

At worst you could have two bluecurve icon themes - one for kde and one for
gnome, but I'm sure that you could just make a bluecurve theme that uses the
gnome way, but that installs system links to let kde find the files where it
expects to find them.

Say "Accessories" is gnome-utils.png in gnome and kde-accessories.png in kde:
you call the bluecurve accessories icon gnome-utils.png and install a symbolic
link to gnome-utils.png and call it kde-accessories.png

That is what I meant by linking...
Comment 13 Justin Georgeson 2003-10-08 15:04:46 EDT
mark: What you describe is more or less how it works now. The menus are
configured with mostly DE agnostic icon names. When you specify an icon theme,
in either GNOME or KDE, either that theme or the theme it inherits must have an
icon of the same name as the menu item specifies. Bluecurve covers both
environments very consistently. That was one of the major complaints with RH 8
(although I think it was a huge step forward). So if you use a different theme
which does not inehrit from Bluecurve (which they all do by default thanks to
/usr/share/icons/default/), then replacements for the redhat-*.png icons must be
provided in your chosen theme. The ones the gnome-icon-theme symlinks to to
replace these redhat-*.png icons are missing. Using a redhat-*.png means RH has
one menu setup with one set of icons (Bluecurve) that works in both GNOME and KDE.
Comment 14 Alexander Larsson 2003-10-09 07:16:33 EDT
mark: Are you saying we should use differeng menus for gnome and KDE? How elese
would you get different icon names in kde and gnome. Thats just not gonna happen.
Comment 15 Alexander Larsson 2003-10-09 07:36:32 EDT
Ok. gnome-icon-theme 1.0.9-2 fixes the symlinks. The icons didn't get removed,
just moved.
Comment 16 Mark Finlay 2003-10-09 15:18:06 EDT
alex: Sorry for filling this bug with ignorant rambing. I really didn't know
what I was talking about.

I can confirm that now Bluecurve and The Gnome icon theme work, but it would be
nice to make sure that random icon themes off art.gnome.org work and that
gnome-themes-extras works.
Comment 17 Alexander Larsson 2003-10-10 05:32:30 EDT
mark: Yes, it would be nice if the icon themes were actually shared, as opposed
to  just using the same mechanism. I don't see this happening though.

Note You need to log in before you can comment on or make changes to this bug.