Bug 1063089 - gnutls.x86_64 0:3.1.20-1.fc20 causes "Cannot run c compiled programs" and XBMC crashes upon exit
Summary: gnutls.x86_64 0:3.1.20-1.fc20 causes "Cannot run c compiled programs" and XBM...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnutls
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Nikos Mavrogiannopoulos
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-10 00:51 UTC by Jerry
Modified: 2014-02-24 08:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-13 15:59:08 UTC


Attachments (Terms of Use)
config.log (14.58 KB, text/plain)
2014-02-10 14:45 UTC, Jerry
no flags Details
valgrind on xbmc.bin #1 (5.86 MB, text/plain)
2014-02-13 15:28 UTC, Jerry
no flags Details

Description Jerry 2014-02-10 00:51:31 UTC
Description of problem:
gnutls.x86_64 0:3.1.20-1.fc20 causes "cannot run c compiled programs" error when compiling XBMC and also crashes the program upon exit.  Downgrade to gnutls.x86_64 3.1.16-1 fixes the problem.

Version-Release number of selected component (if applicable):
gnutls.x86_64 0:3.1.20-1.fc20

How reproducible:
Very repoducible

I spent about three hours with frequent breaks tracking this down as I'm merely an amateur linux sleuth.

I hope this helps someone! :)

Comment 1 Nikos Mavrogiannopoulos 2014-02-10 07:17:20 UTC
Hello,
 Could you specify which version of XBMC you tried to compile, and from where you obtained it? Also what is the specific error that you see and at which stage of the compilation (do you see it on configure time, or compilation time?).

Comment 2 Jerry 2014-02-10 14:45:35 UTC
Created attachment 861427 [details]
config.log

Thank you for your quick reply!

It happens with both XBMC 13.0 Alpha 10 and Alpha 11.  I am seeing the error during configure.  Attached is the config.log.  I was able to compile the source rpm yesterday morning before doing an update on my virtual machine.  The last update I had done was a week ago.  After the update, the configure script failed on the segfault shown in the config.log.  I made a list of packages upgraded by yum update that were listed in the gdb backtrace given by XBMC and downgraded each in turn until I found the one that caused the error.

When running XBMC, there is a crash upon exit.  XBMC creates a crash log upon exit and then restarts itself instead of exiting to the shell.  This happens on my virtual machine running Fedora 20 with all updates and my working machine, also with all updates.

I have tried with the 3.12-8 kernel as well and the same things happen.

I hope this is more clear now.

Comment 3 Jerry 2014-02-10 17:40:01 UTC
(In reply to Nikos Mavrogiannopoulos from comment #1)
> Hello,
>  Could you specify which version of XBMC you tried to compile, and from
> where you obtained it? Also what is the specific error that you see and at
> which stage of the compilation (do you see it on configure time, or
> compilation time?).

I'm sorry, I neglected to mention the source.  I got the source rpm from RPMFusion.

http://download1.rpmfusion.org/free/fedora/releases/20/Everything/x86_64/os/xbmc-13.0-0.2.Gotham_alpha9.fc20.x86_64.rpm

I changed the rpm to download the Alpha 11 version of XBMC.  This also happens with the unchanged rpm.  I just tried it again to be sure.

The error is a segfault in the configure script as I said in my last comment.

Comment 4 Nikos Mavrogiannopoulos 2014-02-11 10:20:36 UTC
How did you correlated this issue with "gnutls.x86_64 0:3.1.20-1.fc20"? It seems that on of the configure scripts crashes while testing the compiler. I believe that this bug should be assigned to xbmc, and if there is some issue in gnutls found out, please follow up.

Comment 5 Nikos Mavrogiannopoulos 2014-02-13 14:03:52 UTC
(In reply to Jerry from comment #2)
> When running XBMC, there is a crash upon exit.  XBMC creates a crash log
> upon exit and then restarts itself instead of exiting to the shell.  This
> happens on my virtual machine running Fedora 20 with all updates and my
> working machine, also with all updates.

btw. You could get more information about the crash by installing the debugging symbols (of gnutls and xbmc) and run valgrind on the executable.

Comment 6 Jerry 2014-02-13 15:28:42 UTC
Created attachment 862844 [details]
valgrind on xbmc.bin #1

I did get xbmc to compile by removing the reference to the mysql library and
the hdhomerun in the spec file.  Unfortunately, it still crashes upon exit.  I'm
trying to track down the cause on the xbmc forum, with the devs doing the suggestions.

I did as you said and ran valgrind against the xbmc executable.  I don't know much about valgrind and used this command line that I found on an introductory page:

valgrind --tool=memcheck --leak-check=yes --show-reachable=yes --num-callers=20 --track-fds=yes /usr/lib64/xbmc/xbmc.bin > valgrind.txt 2>&1

That generated a lot of text on the crash.  I did a grep on gnutls and only found the point where it initialized.  There may be more information there.  I have attached the log.

If you have a command line that would be more effective, I'll try that as well.

Thanks,
Jerry

Comment 7 Nikos Mavrogiannopoulos 2014-02-13 15:59:08 UTC
The valgrind log doesn't show anything suspicious on gnutls (except a small memory leak). Most probably the change in gnutls version (and size) has uncovered an unrelated bug in xbmc. I'll close the bug, but feel free to re-open if more information is available and I'm proven wrong.

Comment 8 Jerry 2014-02-15 11:10:39 UTC
Hi Nikos,

The xbmc guys had me run a gdb backtrace and they think it's crashing in a system library somewhere.  Here is the link to the backtrace: http://xbmclogs.com/show.php?id=131393

I'm not sure if that sheds any light on the situation.  I installed nearly 4 GB of debug information!

Does that make any more sense or is the situation still unclear?

Comment 9 Nikos Mavrogiannopoulos 2014-02-18 16:13:43 UTC
There is no crash in the log that you sent. The interruptions are due to thread creation.

Comment 10 Jerry 2014-02-24 00:40:12 UTC
Here is a crash in zabbix which seems to be related to a gnutls upgrade:

https://bugzilla.redhat.com/show_bug.cgi?id=1064300

Comment 11 Ken Dreyer 2014-02-24 05:59:19 UTC
See also https://bugzilla.redhat.com/show_bug.cgi?id=1069079 for a trivial reproduction case unrelated to RPM Fusion packages.

Comment 12 Nikos Mavrogiannopoulos 2014-02-24 08:47:47 UTC
Thanks. It seems there is an issue in libtspi. I've re-assigned the bug accordingly.


Note You need to log in before you can comment on or make changes to this bug.