This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 106317 - Incorrect Serbian cyrillic glyphs in URW-CYR fonts
Incorrect Serbian cyrillic glyphs in URW-CYR fonts
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: urw-fonts (Show other bugs)
9
All Linux
medium Severity high
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-05 06:38 EDT by Danilo Segan
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-06 13:55:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Danilo Segan 2003-10-05 06:38:21 EDT
Most cyrillic characters that are used only in Serbian are incorrect in URW-CYR
fonts by Valek Fillipov.

I don't use RedHat, so I hesitated to report this, but I received many reports
about people seeing "lowercase cyrillic t" instead of "cj" on RedHat systems,
and none of them was willing to report it. Because of this, it's impossible to
type Serbian language in default RedHat installations (and most reporters have
done what I don't want them to do -- they've used Microsoft's fonts, instead of
free fonts)

Around 18 months ago I've submitted corrected glyphs to Valek, but he never
found time to incorporate them. I'm cleaning them up a bit, and I will submit
them later if you care to include them in those fonts included with RedHat (I
already have done all the glyphs for those 30+ fonts).

Another resolution might be to remove these unfinished glyphs even if you're not
willing to accept my corrections, because that would enable fontconfig to find
another font with probably correct glyphs (even -misc-fixed-*-iso10646-1
contains correct glyphs, as well as cyrillic bitmap fonts in standard XFree86).

Packaged ghostcript 8.11 fonts also contain this bug, because they're just
repackaged URW-CYR fonts.

If this component ("urw-fonts") corresponds only to old URW fonts which were
shipped with Ghostscript, please reassign to correct component.
Comment 1 Danilo Segan 2004-02-21 04:49:01 EST
More info and discussion of the solution available in Debian bug
tracking system: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=230840
Comment 2 Ngo Than 2004-12-06 13:55:10 EST
Danilo, it looks like Valek has also added your changes in
urw-fonts-1.0.7pre38.tar.bz2. closing bug as "fix in currentrelease"
Comment 3 Danilo Segan 2004-12-06 18:55:57 EST
Yes, he actually improved those glyphs, so they're better than what I had.

Thanks

Note You need to log in before you can comment on or make changes to this bug.