Bug 1063343 (Cumulative_RX_TX_Statistics_VDSM_Engine) - [RFE] [Monitoring] Report total RX/TX byte statistics for hypervisor and VM network interfaces
Summary: [RFE] [Monitoring] Report total RX/TX byte statistics for hypervisor and VM n...
Keywords:
Status: CLOSED ERRATA
Alias: Cumulative_RX_TX_Statistics_VDSM_Engine
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.3.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Marcin Mirecki
QA Contact: Meni Yakove
URL:
Whiteboard:
: 848415 1161299 (view as bug list)
Depends On: Cumulative_RX_TX_Statistics_VDSM 1227793
Blocks: 1118699 1196640 1197638 1201335 1202311 1215587 1228991
TreeView+ depends on / blocked
 
Reported: 2014-02-10 14:32 UTC by Anand Nande
Modified: 2019-10-10 09:14 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
This feature reports RX/TX byte statistics for host NICs and virtual machine NICS. In the Administration Portal, the Network Interfaces tab of hosts and virtual machines shows statistics for Rx Rate, Tx Rate, Total Rx, Total Tx, and Drops. The REST API (api/hosts/<host id>/nics/<nic id>/statistics) returns statistics for data.current.rx, data.current.tx, data.total.rx, data.total.tx, errors.total.rx, and errors.total.tx. The drops/errors statistics allow you to check the NIC's health and avoid errors associated with NICs experiencing network issues.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:42:44 UTC
oVirt Team: Network
nyechiel: Triaged+


Attachments (Terms of Use)
Workaround to poll cumulative VM network usage via Python SDK (2.68 KB, text/plain)
2014-11-11 10:10 UTC, Lior Vernia
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC

Comment 4 Itamar Heim 2014-07-03 09:03:29 UTC
*** Bug 848415 has been marked as a duplicate of this bug. ***

Comment 7 Lior Vernia 2014-11-11 10:10:49 UTC
Created attachment 956204 [details]
Workaround to poll cumulative VM network usage via Python SDK

Explained how this works (as well as limitations of the script) on the users@ovirt.org mailing list.

Comment 8 Lior Vernia 2014-11-12 11:41:11 UTC
*** Bug 1161299 has been marked as a duplicate of this bug. ***

Comment 9 Robert McSwain 2014-11-18 15:10:07 UTC
Providing an easy link to the thread Lior mentioned: 
http://lists.ovirt.org/pipermail/users/2014-November/029048.html

Comment 11 Lior Vernia 2015-02-11 15:52:34 UTC
The feature has just been merged and should be available in oVirt/RHEV 3.6.

Comment 16 Michael Burman 2015-11-05 08:11:34 UTC
Verified on -  3.6.0.3-0.1.el6 and vdsm-4.17.10.1-0.el7ev.noarch

Comment 18 errata-xmlrpc 2016-03-09 20:42:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.