Bug 1063666 - [comps] [environments] dnf group remove "GNOME Desktop"
[comps] [environments] dnf group remove "GNOME Desktop"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ales Kozumplik
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2014-02-11 03:28 EST by Jan Synacek
Modified: 2014-09-30 19:42 EDT (History)
8 users (show)

See Also:
Fixed In Version: dnf-plugins-core-0.0.8-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-31 19:58:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Synacek 2014-02-11 03:28:39 EST
Description of problem:
I have a freshly updated rawhide machine (as of today) and executing this command results in a traceback.


Version-Release number of selected component (if applicable):
dnf-0.4.13-2.fc21.noarch


Steps to Reproduce:
1. on a rawhide machine, execute:
   # dnf group remove "GNOME Desktop"
2. observer


Actual results:
# dnf group remove "GNOME Desktop"
Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 124, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1454, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 724, in run
    return self.base.removeGroups(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 922, in removeGroups
    cnt += self.group_remove(group_string)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 1374, in group_remove
    raise dnf.exceptions.CompsError(_("No Group named %s exists") % to_unicode(grpid))
NameError: global name 'grpid' is not defined


Expected results:
Remove the packages that are specified by the group, or say that "group does not exists" or something similar.
Comment 1 Jan Synacek 2014-02-11 03:31:36 EST
Additional info:
# yum group remove "GNOME Desktop"
...
No group named GNOME Desktop exists
...
Comment 2 Parag Nemade 2014-02-11 03:44:32 EST
Did "dnf group list" show that "GNOME Desktop" is installed environment group? Just my thought that might be dnf has not got the similar fix that yum got. dnf is not showing Installed environment groups.

When I installed some environments fully and tried to install them again I got
Error: No packages in any requested group available to install or upgrade.
Comment 3 Jan Synacek 2014-02-11 04:05:50 EST
I'm not sure, I already uninstalled a lot of packages manually. However, "dnf group list" shows "GNOME Desktop" in Available environment groups.
Comment 4 Parag Nemade 2014-02-11 04:16:27 EST
I just quickly grep into source code for string "Installed environment groups" and found no results. I think that coding part yet not added in dnf to show installed environments.
Also, if you try to remove any installed group from the "dnf group list" output then it is not giving any traceback.
Comment 5 Ales Kozumplik 2014-02-11 08:41:31 EST
Looking.
Comment 6 Ales Kozumplik 2014-02-11 15:42:43 EST
The traceback is fixed in 00f88e4.

Note that "GNOME Desktop" is a group and not an environment and environment support is sort of iffy in DNF. The proper fix awaits overhaul to groups-as-objects.
Comment 7 Ales Kozumplik 2014-02-11 15:44:02 EST
(In reply to Ales Kozumplik from comment #6)
> Note that "GNOME Desktop" is a group and not an environment and environment

*is an environment and not a group*. it's been a long today.
Comment 8 Ales Kozumplik 2014-02-19 15:20:57 EST
*** Bug 1067136 has been marked as a duplicate of this bug. ***
Comment 9 Ales Kozumplik 2014-03-11 11:25:26 EDT
It's time to add the groups-as-objects support and fix the environments.
Comment 10 Ales Kozumplik 2014-03-25 15:55:53 EDT
Fixed by cf1d32b.
Comment 11 Fedora Update System 2014-05-02 04:32:08 EDT
dnf-0.5.1-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.5.1-1.fc20
Comment 12 Fedora Update System 2014-05-02 17:04:40 EDT
Package dnf-0.5.1-1.fc20, hawkey-0.4.14-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.5.1-1.fc20 hawkey-0.4.14-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-5937/hawkey-0.4.14-1.fc20,dnf-0.5.1-1.fc20
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2014-05-28 08:09:59 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
Comment 14 Fedora Update System 2014-05-28 19:49:57 EDT
Package dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-plugins-core-0.0.8-2.fc20 libsolv-0.6.1-1.git6d968f1.fc20 hawkey-0.4.16-1.fc20 dnf-0.5.2-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-6789/libsolv-0.6.1-1.git6d968f1.fc20,hawkey-0.4.16-1.fc20,dnf-0.5.2-1.fc20,dnf-plugins-core-0.0.8-2.fc20
then log in and leave karma (feedback).
Comment 15 Fedora Update System 2014-05-31 19:58:30 EDT
dnf-plugins-core-0.0.8-2.fc20, libsolv-0.6.1-1.git6d968f1.fc20, hawkey-0.4.16-1.fc20, dnf-0.5.2-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.