Bug 1067136 - [comps] no way to install optional packages from a group
Summary: [comps] no way to install optional packages from a group
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ales Kozumplik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 19:17 UTC by Mukundan Ragavan
Modified: 2014-09-30 23:42 UTC (History)
5 users (show)

Fixed In Version: dnf-0.4.19-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 08:13:43 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mukundan Ragavan 2014-02-19 19:17:34 UTC
Description of problem:

dnf grouplist produces list of available groups. When I choose a particular group from the output, it does not perform the installation.

The exact same process in yum works fine.

Version-Release number of selected component (if applicable):
# rpm -qa dnf
dnf-0.4.14-1.fc20.noarch

How reproducible:
Always

Steps to Reproduce:
1.

# dnf grouplist
Available environment groups:
   Basic Desktop
   GNOME Desktop
   KDE Plasma Workspaces
   Cinnamon Desktop
   Xfce Desktop
   LXDE Desktop
   Infrastructure Server
   Sugar Desktop Environment
   Development and Creative Workstation
   MATE Desktop
<output snipped>

2.

# dnf groupinstall "KDE Plasma Workspaces"
Warning: Group KDE Plasma Workspaces does not exist.
Error: No packages in any requested group available to install or upgrade.

# dnf groupinstall "MATE Desktop"
Warning: Group MATE Desktop does not exist.
Error: No packages in any requested group available to install or upgrade.


Actual results:
dnf does not install the group it lists.

Expected results:
dnf should be able to install the group.

Additional info:
Some groups work while other don't.

For example, "Educational Software" does not work but "System Tools" works.

Comment 1 Ales Kozumplik 2014-02-19 20:20:57 UTC
Hello, this is a dupe of bug 1063666, 'MATE Desktop' etc. are 'environments' and DNF does not support these yet.

*** This bug has been marked as a duplicate of bug 1063666 ***

Comment 2 Mukundan Ragavan 2014-02-19 20:23:50 UTC
Just a quick question - the example "Educational Software" vs "System Tools"? Is it a comps in general or specific to environments?

Thanks for you comment.

Comment 3 Ales Kozumplik 2014-02-19 20:30:46 UTC
what does

dnf group install 'Educational Tools'

output on your machine?

Comment 4 Mukundan Ragavan 2014-02-19 20:41:03 UTC
I am using "Educational Software" and "Medical Applications" (instead of system tools as I had mentioned in #1) as example because both these groups are listed under "Available groups".



root @ carbon ~# dnf group install "Educational Software"
Warning: Group education does not have any packages.
Error: No packages in any requested group available to install or upgrade.

root @ carbon ~# dnf group install 'Educational Software'
Warning: Group education does not have any packages.
Error: No packages in any requested group available to install or upgrade.



root @ carbon ~# dnf group install "Medical Applications"
Resolving dependencies
--> Starting dependency resolution
---> Package aeskulap.x86_64 0.2.2-0.17beta1.fc20 will be installed
---> Package dcmtk.x86_64 3.6.0-16.fc20 will be installed
---> Package gconfmm26.x86_64 2.28.3-6.fc20 will be installed
---> Package libglademm24.x86_64 2.6.7-9.fc20 will be installed
---> Package CharLS.x86_64 1.0-6.fc20 will be installed
---> Package gnumed.noarch 1.4.5-1.fc20 will be installed
---> Package gnuplot-py.noarch 1.8-14.fc20 will be installed
---> Package libxslt-python.x86_64 1.1.28-5.fc20 will be installed
---> Package python-hl7.noarch 0.2.0-6.fc20 will be installed
---> Package python-pillow-sane.x86_64 2.2.1-2.fc20 will be installed
---> Package python-psycopg2.x86_64 2.5.1-2.fc20 will be installed
---> Package wxPython.x86_64 2.8.12.0-5.fc20 will be installed
---> Package xsane.x86_64 0.999-7.fc20 will be installed
---> Package wxGTK-gl.x86_64 2.8.12-9.fc20 will be installed
---> Package wxGTK-media.x86_64 2.8.12-9.fc20 will be installed
---> Package xsane-common.x86_64 0.999-7.fc20 will be installed
---> Package gnumed-server.noarch 19.5-1.fc20 will be installed
---> Package postgresql-server.x86_64 9.3.2-2.fc20 will be installed
---> Package postgresql.x86_64 9.3.2-2.fc20 will be installed
---> Package postgresql-libs.x86_64 9.3.2-2.fc20 will be installed
---> Package python-egenix-mx-base.x86_64 3.2.5-3.fc20 will be installed
---> Package aspell.x86_64 12:0.60.6.1-8.fc20 will be installed
---> Package gnupg.x86_64 1.4.16-2.fc20 will be installed
---> Package xmedcon.x86_64 0.10.7-12.fc20 will be installed
---> Package libtpcimgio.x86_64 1.5.10-8.fc20 will be installed
---> Package libtpcmisc.x86_64 1.4.8-8.fc20 will be installed
---> Package nifticlib.x86_64 2.0.0-8.fc20 will be installed
--> Finished dependency resolution
Dependencies resolved.

Comment 5 Ales Kozumplik 2014-02-20 07:08:16 UTC
OK, this is in fact another error. Reopenng.

Comment 6 Ales Kozumplik 2014-03-17 08:29:26 UTC
Upstream commit 234e1fb243ed35284ea8a948b26d7aa4d20a4acf allows installation of optional packages using 'dnf group install with-optional <group>'.

Comment 7 Fedora Update System 2014-03-17 09:45:35 UTC
dnf-0.4.18-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.18-1.fc20

Comment 8 Fedora Update System 2014-03-18 08:10:42 UTC
Package dnf-0.4.18-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dnf-0.4.18-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3999/dnf-0.4.18-1.fc20
then log in and leave karma (feedback).

Comment 9 Fedora Update System 2014-03-24 09:06:04 UTC
dnf-0.4.19-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dnf-0.4.19-1.fc20

Comment 10 Fedora Update System 2014-03-25 08:13:43 UTC
dnf-0.4.19-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.