Bug 106387 - gnumeric segfaults on start
gnumeric segfaults on start
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnumeric (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-06 13:10 EDT by Tim Waugh
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-05 09:48:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
backtrace (4.34 KB, text/plain)
2003-10-08 13:16 EDT, Tim Waugh
no flags Details

  None (edit)
Description Tim Waugh 2003-10-06 13:10:55 EDT
Description of problem:
gnumeric segfaults on start

Version-Release number of selected component (if applicable):
gnumeric-1.2.0-1, current rawhide

How reproducible:
100%

Steps to Reproduce:
1. Launch gnumeric.
    
Actual results:
Dialog complains about fatal error (Aborted)

Backtrace was generated from '/usr/bin/gnumeric'

(no debugging symbols found)...Using host libthread_db library
"/lib/tls/libthread_db.so.1".
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...[Thread debugging using libthread_db enabled]
[New Thread 1077917792 (LWP 2460)]
(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#0  0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x40150963 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
#2  0x4007f7f4 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#5  0x4019f98f in raise () from /lib/tls/libc.so.6
#6  0x401a1302 in abort () from /lib/tls/libc.so.6
#7  0x0043ff38 in g_logv () from /usr/lib/libglib-2.0.so.0
#8  0x0043ff74 in g_log () from /usr/lib/libglib-2.0.so.0
#9  0x4012da28 in link_protocol_find_num () from /usr/lib/libORBit-2.so.0
#10 0x4012df80 in link_servers_move_io_T () from /usr/lib/libORBit-2.so.0
#11 0x00437fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
#12 0x00438fd8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#13 0x004392ef in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#14 0x004399cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#15 0x006ea44f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x086485e8 in ?? ()

Thread 1 (Thread 1077917792 (LWP 2460)):
#0  0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#1  0x40150963 in __waitpid_nocancel () from /lib/tls/libpthread.so.0
No symbol table info available.
#2  0x4007f7f4 in libgnomeui_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
No symbol table info available.
#5  0x4019f98f in raise () from /lib/tls/libc.so.6
No symbol table info available.
#6  0x401a1302 in abort () from /lib/tls/libc.so.6
No symbol table info available.
#7  0x0043ff38 in g_logv () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#8  0x0043ff74 in g_log () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#9  0x4012da28 in link_protocol_find_num () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#10 0x4012df80 in link_servers_move_io_T () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#11 0x00437fdd in unblock_source () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#12 0x00438fd8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#13 0x004392ef in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#14 0x004399cf in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#15 0x006ea44f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
No symbol table info available.
#16 0x086485e8 in ?? ()
No symbol table info available.
#0  0x40000c32 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
Comment 1 Owen Taylor 2003-10-07 16:04:57 EDT
Could you try upgrading your ORBit2, libbonobo, libbonobo-activation,
and see if that fixes the problem?

What's the base OS you are running on?
Comment 2 Tim Waugh 2003-10-08 08:31:30 EDT
ORBit2-2.8.1.90-1
libbonobo-2.4.0-1

Fedora Core (rawhide).
Comment 3 Owen Taylor 2003-10-08 12:23:23 EDT
I can't reproduce. Can you install debuginfo packages to get a better
backtrace? (At least gnumeric, ORBit2, glib2)
Comment 4 Tim Waugh 2003-10-08 13:16:45 EDT
Created attachment 95023 [details]
backtrace
Comment 5 Chris Ricker 2003-11-05 09:40:10 EST
This is probably closable -- it seems to start fine now
Comment 6 Tim Waugh 2003-11-05 09:48:33 EST
Agreed.

Note You need to log in before you can comment on or make changes to this bug.