Bug 106389 - grub is not installed properly when using software raid + LVM
Summary: grub is not installed properly when using software raid + LVM
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: rawhide
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-06 17:37 UTC by Edward Muller
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 18:35:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Edward Muller 2003-10-06 17:37:21 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
Ran through a new install of test2 over the weekend. I have two 200 GB Maxtor
drives (hde and hdg on a promise TX133 controller).

Using Disk Druid, I created a three partitions on each drive. The partitions are:

256 MB
2000 MB
the rest of the drive.

I created md0 (RAID1) using the two 256 MB partitions and set the mount point to
/boot (it is shown as being at the front of the disk).

I created md1 (RAID1) using the two 2000 MB partitions and set the type to swap.

I created md2 (RAID1) using the last two partitions.

I then set md2 as a physical volume.

I then used the LVM button to create Logical Volumes /, /home, /var, /tmp, /usr,
etc.

/dev/hda is my boot device. This is plugged into the IDE built into the motherboard.

Install finished normally without any errors, but when I rebooted GRUB did not load.

I rebooted with the the install CD using "linux rescue" and chrooted into the
install...

I tried running grub-install --recheck and then rebooting. It didn't work.

I rebooted with the install CD again, then ran 'grub --batch'...

root(hd2,0)
setup(hd0)
quit

When I rebooted again (without the CD) grub was working.

Let me know if you need any more info.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Install Fedora test2 to md (RAID1)/LVM combo described above.
2.
3.
    

Actual Results:  won't boot on restart

Expected Results:  will boot on restart.

Additional info:

Comment 1 Jeremy Katz 2003-10-14 21:31:27 UTC
Can you attach the /boot/grub/device.map and /boot/grub/grub.conf generated by
the installer?

Comment 2 Jeremy Katz 2004-09-22 18:35:26 UTC
Closing due to lack of activity.  Please reopen if you have further
information to add to this bug report.


Note You need to log in before you can comment on or make changes to this bug.