Bug 1064474 - [RFE][WEBADMIN] Option to populate LUN description with LUN ID #
Summary: [RFE][WEBADMIN] Option to populate LUN description with LUN ID #
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ovirt-3.6.0-rc
: 3.6.0
Assignee: Tal Nisan
QA Contact: Ori Gofen
URL:
Whiteboard:
Depends On:
Blocks: 1252738
TreeView+ depends on / blocked
 
Reported: 2014-02-12 16:43 UTC by Guil Barros
Modified: 2019-08-15 03:49 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
It is now possible to populate the description of a new LUN disk with all, none, or part of the LUN id. The default setting uses the last four digits of the LUN id and can be configured via engine-config-manager. This value can be set to '-1' for the full LUN id to be used, or '0' for this feature to be ignored. A positive integer will populate the description with the corresponding number of characters of the LUN id.
Clone Of:
Environment:
Last Closed: 2016-03-09 20:43:46 UTC
oVirt Team: Storage
sherold: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2016:0376 normal SHIPPED_LIVE Red Hat Enterprise Virtualization Manager 3.6.0 2016-03-10 01:20:52 UTC
oVirt gerrit 37088 master MERGED webadmin: When creating LUN disk populate the description with the LUN id Never

Description Guil Barros 2014-02-12 16:43:21 UTC
When adding LUN's auto populate the Description with the last 4 
characters of the LUN ID

Comment 7 Allon Mureinik 2014-12-16 15:57:33 UTC
Wait a sec, I think we have our signals crossed here - are we talking about LUN DISKS or LUNs which make up a STORAGE DOMAIN?

Comment 8 Allon Mureinik 2015-01-19 16:56:02 UTC
(In reply to Guil Barros from comment #0)
> When adding LUN's auto populate the Description with the last 4 
> characters of the LUN ID
4 characters sounds like an arbitrary number - it may very well fit a specific customer, but for a generic solution, let's have some configuration value that determines this (including the option to take the entire LUN ID, or nothing at all).

Comment 9 Allon Mureinik 2015-01-22 10:03:00 UTC
Tal, please add the patch info to the tracker.

Comment 10 Ori Gofen 2015-05-26 11:41:24 UTC
comment #8 sounds reasonable, are we sticking with the last 4 digits idea?

Comment 11 Tal Nisan 2015-05-26 13:03:38 UTC
I've written all the info in the doc text:

"This RFE gives the option when creating a new LUN disk via webadmin to populate the disk description by default with a part of the LUN id.
By default the 4 last characters of the LUN id will be the disk description but this value is configurable by the config value "PopulateDirectLUNDiskDescriptionWithLUNId" (also via engine config manager)
If this config value contains -1 the entire LUN id will be copied to the description, if the value contains 0 the description will not be affected and any positive number indicates the number of characters from the description to populate the disk description with"

Comment 12 Ori Gofen 2015-05-26 13:18:02 UTC
btw in our vnx-emc^2 environment all Lun id's end with 'e311', which results to all disks having the same description 'e311'

Comment 13 Tal Nisan 2015-05-26 13:50:13 UTC
That's exactly why you should configure the value to allow more digits to be auto populated

Comment 14 Ori Gofen 2015-05-26 14:29:02 UTC
yes Tal, I did, thank you, it works well, the problem is that I don't understand why the default behavior is 'last 4 digits', last 4 digits are not unique to every environment.
the default configuration ought to be generic

Comment 15 Tal Nisan 2015-05-26 14:35:40 UTC
What do you mean that the default configuration should be generic? How can it be generic if it has to be predefined?
And in our environment for instance the last 4 digits are different in each LUN for instance, we start with 4 as the default and the user has the the option to have as many digits as he want or the full LUN id

Comment 16 Ori Gofen 2015-05-26 14:46:24 UTC
generic is to have the whole Lun-id by default, or not to have any Lun-id populating the description and let the user decide what kind of configuration he wants

Comment 17 Tal Nisan 2015-05-26 15:12:51 UTC
LUN ids can be long, we decided to let the user have 4 digits by default, the documentation specifies how to change it to each of the options you suggested or for other amount of digits.

Comment 18 Ori Gofen 2015-05-27 11:21:37 UTC
Verifed on ovirt3.6.0.1

Comment 20 Tal Nisan 2015-10-06 13:09:26 UTC
Andrew, the doc text seems correct, might be worth to note that the configured value should be set to 0 to included no part of the id in the description and -1 to include the full id

Comment 21 Andrew Burden 2015-10-20 02:38:42 UTC
Thanks for that, Tal. Updated as suggested.

Comment 23 errata-xmlrpc 2016-03-09 20:43:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0376.html


Note You need to log in before you can comment on or make changes to this bug.