Bug 106452 - aspell upgrade nigh impossible
aspell upgrade nigh impossible
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: aspell (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On: 106453 106455
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 05:50 EDT by Max Kanat-Alexander
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-10 12:35:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2003-10-07 05:50:32 EDT
It's possible that this is NOTABUG, but I thought that it should be documented.

RH9 comes with aspell-0.33.7.1-21. Rawhide now contains only aspell-0.50.3-15.

Aspell-0.50.3-15 both provides and obsoletes pspell. RH9 comes with
pspell-0.12.2-16.

Attempting to install the new aspell over the old one will remove pspell.
However, a lot of applications depend on pspell. Thus, the upgrade path from the
old aspell to the new aspell is as follows:

1) Upgrade to aspell-en-0.51-6
2) Install or force (with --nodeps) an Upgrade to aspell-0.50.3-15.
3) If you compiled aspell-en-0.51-6 from the SRPM, rebuild it and install it
again. (That's getting a separate bug.)
4) Recompile and reinstall gtkspell.
5) Recompile and resintall gnome-spell.
6) Recompile and reinstall (or remove): balsa, php, abiword, and gaim (although
that might not work -- that's getting another bug).

It's not a bug against rawhide as it stands, but it is a bug for an upgrade
path, since I had to do that --nodeps in the middle, there.

I'm not sure what happens if you just install (and don't force an upgrade) and
keep both versions of aspell. I'm not sure it would work, though I don't know.

Also, there's two other bugs up there which I'll note as blocking this one when
I file them.

Version-Release number of selected component (if applicable):
aspell-0.50.3-15

How reproducible:
Always
Comment 1 Max Kanat-Alexander 2003-10-07 06:18:52 EDT
The fact that gaim won't build against the new aspell is bug 106453.

The problem with aspell and aspell-en is bug 106455.

-M
Comment 2 Eido Inoue 2003-10-10 12:35:59 EDT
smooth upgrading from an official release (RHL9) to rawhide packages is not
officially supported. You may need to massage things with --nodeps and such.
When distributed by the next release or via up2date --update, the applications
that depend on aspell will also be updated with versions that have been compiled
against  the aspell with the new API/ABI.

It's an unfortunate thing that aspell innovation required it to throw away any
API/ABI compatibility with the previous version. :|

Note You need to log in before you can comment on or make changes to this bug.