Bug 106453 - gaim SRPM does not build against what is actually in rawhide
gaim SRPM does not build against what is actually in rawhide
Status: CLOSED WORKSFORME
Product: Red Hat Raw Hide
Classification: Retired
Component: gaim (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker 106452
  Show dependency treegraph
 
Reported: 2003-10-07 06:01 EDT by Max Kanat-Alexander
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 14:04:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2003-10-07 06:01:35 EDT
Description of problem:
Rawhide does not contain pspell as its own package. This is as it should be,
since the new aspell provides pspell compatibility.

However, attempting to build the gaim-0.70-1 SRPM in rawhide on a system that
doesn't have the old pspell package (and only the new aspell-0.50.3-15) results
in an error at link time, saying that one of the pspell libraries couldn't be
found. (I don't have the exact error message on hand, but I'm sure that this is
what it was saying.)

The problem seems to be that the gaim SRPM is libtoolize'd against the wrong
libraries.

The solution would probably be:
Either:
A) Re-libtoolize the gaim package with the correct spelling packages installed.
or
B) Have the gaim SRPM run the aclocal, libtoolize... bit in its %build section.

Also, if that was done, a dependency on the newer aspell would probably be a
good idea, too.


Version-Release number of selected component (if applicable):
gaim-0.70-1

How reproducible:
Always

Steps to Reproduce:
1. Remove old pspell and aspell from your system by forcing an upgrade to the
newest aspell in rawhide.
2. Build the gaim SRPM currently in rawhide with rpmbuild --rebuild.

Actual Results:  Building the RPM fails with a linking error.

Expected Results:  The RPM builds sucessfully.
Comment 1 Christopher Blizzard 2003-10-09 14:04:47 EDT
I just built on a system without any pspell libs on it - no problems.  Same with
the red hat build roots.  Are you sure you're just not running into some
problems on your system?

Note You need to log in before you can comment on or make changes to this bug.