Bug 106456 - gaim should ./configure with --with-perl-lib=%{buildroot}%{_prefix}
gaim should ./configure with --with-perl-lib=%{buildroot}%{_prefix}
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: gaim (Show other bugs)
1.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Blizzard
David Lawrence
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-07 06:35 EDT by Max Kanat-Alexander
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-09 14:06:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Max Kanat-Alexander 2003-10-07 06:35:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030917
Firebird/0.6.1+

Description of problem:
I ran into this bug after I ran into bug 106453.

I changed the spec to re-libtoolize the source (to work around bug 106453), and
all of the sudden it wouldn't build. It attempted to install a perl package into
my actual directory tree, outside of RPM_BUILD_ROOT, and of course failed (since
I have a protected RPM-buiding environment, where the user can't write outside
of the /usr/src/redhat tree except for the temp files and all that).

I think that right now you're handling this with a patch, but it's simpler to
just use --with-perl-lib=%{buildroot}%{_prefix} on the %configure step.

I think that this probably doesn't happen for most people, but I thought that it
would save trouble in the future to do it, and it seems like the more "correct"
way to handle it.

-M

Version-Release number of selected component (if applicable):
gaim-0.70-1

How reproducible:
Always

Steps to Reproduce:
1

Additional info:
Comment 1 Christopher Blizzard 2003-10-09 14:06:27 EDT
Knowing that the other bug isn't an issue I'm closing this since the perl stuff
seems to work OK.
Comment 2 Max Kanat-Alexander 2003-10-11 05:27:40 EDT
Hrm, I can still reproduce the bug every time on my machine, and I've got the
error now:

During build I get:
Warning: You do not have permissions to install into
/usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi at
/usr/lib/perl5/5.8.0/ExtUtils/Install.pm line 84.
mkdir /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi/auto/Gaim:
Permission denied at /usr/lib/perl5/5.8.0/ExtUtils/Install.pm line 137
make[4]: *** [pure_vendor_install] Error 255

And then eventually building the RPM fails with:
rm: cannot remove
`/var/tmp/gaim-0.70-root//usr/lib/perl5/5.8.0/i386-linux-thread-multi/perllocal.pod':
No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.69074 (%install)
    Bad exit status from /var/tmp/rpm-tmp.69074 (%install)

I haven't modified the spec file except to add "athlon" to the ExclusiveArch so
that I can run an optimized build.

Did you test the build as a user who can't write to /usr/lib/perl5/... etc.?

This seems like an unusual thing to just be happening to me. I can't think of
what in my configuration would cause it to happen to only me.

-M
Comment 3 Max Kanat-Alexander 2003-10-11 05:29:49 EDT
Oh, and I should add that it happens if I just build directly from the SRPM --
that is, I said that I re-libtoolized it in the initial report, but that's not
necessary to make this happen.

-M
Comment 4 Christopher Blizzard 2003-10-13 14:54:50 EDT
All of red hat's build are done as a user that can't write to the system
directories.  If you remove the changes you made, does it work?
Comment 5 Max Kanat-Alexander 2003-10-13 18:24:29 EDT
If I remove the changes and build only from the SRPM in rawhide, the failure
still occurs.

-M

Note You need to log in before you can comment on or make changes to this bug.