Bug 10647 - Mount fails with NFS
Mount fails with NFS
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: mount (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Elliot Lee
Brian Brock
:
: 10657 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-04-07 15:36 EDT by Red Hat Bugzilla
Modified: 2008-03-13 15:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-11 12:26:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2000-04-07 15:36:20 EDT
The mount package from Red Hat 6.2/i386 generates errors when trying to
mount NFS volumes.

mount: mount: RPC: Unable to receive; errno = Connection refused

This was not a server issue.  Reverting to the package from 6.1
(mount-2.9u-4) aleviates the problem.

I have installed kernel 2.2.15pre17.
Comment 1 Red Hat Bugzilla 2000-04-07 15:44:59 EDT
Make sure the portmapper is running.
Comment 2 Red Hat Bugzilla 2000-04-07 16:09:59 EDT
Portmap is running.

 1372 ?        S      0:00 portmap

mount-2.9u-4.i386.rpm works just fine.
mount-2.10f-1.i386.rpm and mount-2.10h-1.i386.rpm both behave identically.

/var/log/messages:
Apr  7 16:09:51 lul1168 automount[1637]: attempting to mount entry /emc/rgramc
Apr  7 16:09:51 lul1168 automount[5188]: >> mount: RPC: Unable to receive; errno
= Connection refused
Apr  7 16:09:51 lul1168 automount[5188]: mount(nfs): nfs: mount failure
emcnfs412:/mnt_1203/ucode/rgramc on /emc/rgramc

I see the same behavior when trying to mount manually from the command line, so
it shouldn't be related to the automounter.

The NFS server is an EMC Celerra.

[Note, though the symptoms are different, it could be related to but 10428.]
Comment 3 Red Hat Bugzilla 2000-05-05 17:30:59 EDT
I had the same problem and realized that even though you select NFS server
in the install, the NFS related servers are not automatically run. You have
to start them through init.d via Linuxconf. Just start them up automatically
(or manually) from there and you'll be fine. Not a bug.
Comment 4 Red Hat Bugzilla 2000-05-08 15:50:59 EDT
mchampig@110.net: It has nothing to do with running the NFS server.  I'm not
exporting file systems.  This is entirely a client issue.

I see bug 10657 reports a similar problem; I suspect it's a duplicate of this
one.

So just to be clear, here's exactly what I'm observing (actual cut-and-paste):

root% rpm -q mount
mount-2.9u-4
root% mkdir /tmp/mnt
root% mount emcnfs412:/mnt_1203/ucode/rgramc /tmp/mnt
root% umount /tmp/mnt
root% rpm --upgrade mount-2.10f-1.i386.rpm
root% mount emcnfs412:/mnt_1203/ucode/rgramc /tmp/mnt
mount: RPC: Unable to receive; errno = Connection refused
root% rpm --upgrade --force mount-2.9u-4.i386.rpm
root% mount emcnfs412:/mnt_1203/ucode/rgramc /tmp/mnt
root% umount /tmp/mnt
root% rmdir /tmp/mnt
Comment 5 Red Hat Bugzilla 2000-05-09 02:59:59 EDT
I'd like to report a (more or less) identical problem. The 6.2
version of mount failed an NFS mount of a PC directory exported
by Sun Solstice Network Client 3.2. However, it had no trouble
with NFS mounts from other systems (AIX4.14, and various Linux
systems). The 6.1 version of mount (and prior versions) worked
fine with Sun Solstice Network Client, as well as the other
operating systems.
  Good luck,
  Marshall
Comment 6 Red Hat Bugzilla 2000-05-15 10:59:59 EDT
*** Bug 10657 has been marked as a duplicate of this bug. ***
Comment 7 Red Hat Bugzilla 2000-05-15 11:08:59 EDT
What do
	rpcinfo -e <your_server_here>
	rpcinfo -p <your_server_here>
have to say?

Can you also supply "rpm -q knfsd initscripts kernel mount" info as well?
Comment 8 Red Hat Bugzilla 2000-05-15 11:09:59 EDT
Apologies, that should have been
	showmount -e <your_server_here>
Comment 9 Red Hat Bugzilla 2000-05-15 11:27:59 EDT
Here's the info requested above (and a little more):

% showmount -e emcnfs410
Export list for emcnfs410:
/mnt_1004 (everyone)
/mnt_1006 (everyone)
/mnt_1005 (everyone)
/mnt_1003 (everyone)
/mnt_1002 (everyone)
/         192.1.1.100,192.1.2.100,192.1.1.101,192.1.2.101
% rpm -q knfsd initscripts kernel mount nfs-utils portmap
package knfsd is not installed
initscripts-5.00-1
kernel-2.2.14-5.0
mount-2.9u-4
nfs-utils-0.1.6-2
portmap-4.0-19
% uname -a
Linux lul1168 2.2.15pre17 #1 Thu Apr 6 12:02:29 EDT 2000 i686 unknown

(As you can see, I've bypassed the RPM system to install my own custom-built
kernel.)
Comment 10 Red Hat Bugzilla 2000-05-15 11:40:59 EDT
Note that this is apparently a bug that VA Linux noticed and fixed for their
"VA-enhanced Load."  Check out
http://www.valinux.com/software/vaload/6.2/comparison.html for references.
Their mount-2.10f-1.1.i386.rpm seems to work fine on my system.
Comment 11 Red Hat Bugzilla 2000-05-15 12:59:59 EDT
Just to make the point that it isn't Preson's updated kernel which is causing
the problem:
$ showmount -e 193.63.255.4
Export list for 193.63.255.4:
/public (everyone)
$ rpm -q knfsd initscripts kernel mount nfs-utils portmap
package knfsd is not installed
initscripts-5.00-1
kernel-2.2.14-6.1.1
mount-2.9u-4
nfs-utils-0.1.6-2
portmap-4.0-19
Comment 12 Red Hat Bugzilla 2000-05-15 14:56:59 EDT
Just thought I'd add - the VA Linux mount _doesn't_ fix my problem.
Preston, are you able to mount 193.63.255.4:/public on your system? If so, it
might show that there is an interaction of mount and kernel version, since the
only difference I can see between us is our kernels. Or it might be a problem
with this specific NFS server.
Comment 13 Red Hat Bugzilla 2000-05-16 14:24:59 EDT
Building a 'mount' program using the tarball in mount-2.10f-1.src.rpm works with
EMC servers.  After patching with 'util-linux-2.10f-realpath.patch', 'mount'
still works.

After adding 'util-linux-2.9o-mount-nfsv3.patch', 'mount' fails:

mount: wrong fs type, bad option, bad superblock on
phxc2d4-e2:/users117c2/e021597, or too many mounted file systems

After adding 'util-linux-2.9w-mount-nfsv3try.patch', the 'mount' program fails
to mount from EMC servers, as reported originally.

Note You need to log in before you can comment on or make changes to this bug.