Bug 106471 - Tasks w/o dependencies don't show up in workflow details
Tasks w/o dependencies don't show up in workflow details
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise CMS
Classification: Retired
Component: other (Show other bugs)
nightly
All Linux
medium Severity high
: ---
: ---
Assigned To: ccm-bugs-list
Jon Orris
:
: 107624 (view as bug list)
Depends On:
Blocks: 100952
  Show dependency treegraph
 
Reported: 2003-10-07 10:07 EDT by Jon Orris
Modified: 2007-04-18 12:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-10 11:25:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jon Orris 2003-10-07 10:07:03 EDT
Description of problem:
Create a new workflow.
Add a task.
Return to workflow details.

The number of tasks will read as 1, but no tasks will be displayed.

The problem is that in 
//cms/.../src/com/arsdigita/cms/ui/workflow/TaskTableModelBuilder.java

tasks w/o dependencies aren't added to the graph, so they don't show up at all
when building the sorted list.
Comment 1 Jon Orris 2003-10-07 10:33:29 EDT
Fixed @36757
Merge into troika
Comment 2 Richard Li 2003-10-07 10:47:46 EDT
It's not merged onto Troika, which is 6.0 branch. 36757 only affected trunk.
Comment 3 Jon Orris 2003-10-07 10:53:33 EDT
That's what I meant, but wasn't clear. Merge into Troika -> Needs to merge into
Troika.
Comment 4 Vadim Nasardinov 2003-10-21 08:53:22 EDT
*** Bug 107624 has been marked as a duplicate of this bug. ***
Comment 5 Vadim Nasardinov 2003-10-21 08:56:24 EDT
Why is this marked as private to the Red Hat CCM group?
People outside of Red Hat aren't able to find this bug
and have consequently resubmitted a similar ticket. (See
the comment above.)
Comment 6 Vadim Nasardinov 2003-10-21 09:29:42 EDT
Adding the submitter of
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=107624
to the cc list.
Comment 7 Jon Orris 2003-12-10 11:25:35 EST
Integrated by Archit @37524

Note You need to log in before you can comment on or make changes to this bug.