Bug 106483 - smbclient: -N negates the provided password, despite documentation
Summary: smbclient: -N negates the provided password, despite documentation
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: samba (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-07 17:07 UTC by Tim Waugh
Modified: 2014-08-31 23:25 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-12 21:21:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Samba Project 2051 None None None Never

Description Tim Waugh 2003-10-07 17:07:02 UTC
Description of problem:
Two command lines:

smbclient //server/share password -U user -c quit
smbclient //server/share password -U user -N -c quit

ought to behave in the same way according to the documentation (in fact, the
documentation says that if the password is provided on the command line, -N is
assumed).

In fact the second of these always fails.

Version-Release number of selected component (if applicable):
samba-3.0.0-15

How reproducible:
100%

Steps to Reproduce:
1. See above.
    
Additional info:
Didn't happen before 3.

Comment 1 Jay Fenlason 2004-11-17 21:02:30 UTC
I've confirmed that this is a code bug, and opened it upstream: 
https://bugzilla.samba.org/show_bug.cgi?id=2051 

Comment 2 Jay Fenlason 2005-09-12 21:21:29 UTC
I include a patch in the 3.0.20 RawHide RPM.  Let me know if it fixes the 
problem for you so I can send it upstream. 

Comment 3 Tim Waugh 2005-09-13 08:35:23 UTC
I worked around this long ago.  It is simple to test yourself.

Comment 4 Tomasz Ostrowski 2005-12-28 16:52:07 UTC
This patch breaks smbclient tar file creation with
    smbclient //server/share -A server.auth -Tc /tmp/server-share.tar
as described in bug #176649.

Comment 5 Simo Sorce 2007-03-28 16:08:27 UTC
This is not a code bug, but a documentation issue.
-N really mean No Password, if you use it it means you don't want to send a
password and that's what the code does (yes it ignores the password you set on
the command line by design).
I fixed the documentation upstream to better explain this.
(Re)closing this bug as NOTABUG


Note You need to log in before you can comment on or make changes to this bug.