Bug 1065270 - [RHEVM] [webadmin] [network labels] Setup Host Networks dialog presents network configuration incorrectly
Summary: [RHEVM] [webadmin] [network labels] Setup Host Networks dialog presents netwo...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.4.0
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1024889 1064953
TreeView+ depends on / blocked
 
Reported: 2014-02-14 08:48 UTC by Martin Pavlik
Modified: 2014-04-01 05:00 UTC (History)
10 users (show)

Fixed In Version: av3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:47 UTC
oVirt Team: ---


Attachments (Terms of Use)
logs from host (1.35 MB, application/x-compressed-tar)
2014-02-14 08:48 UTC, Martin Pavlik
no flags Details
logs from engine (2.82 MB, application/x-compressed-tar)
2014-02-14 08:49 UTC, Martin Pavlik
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1064953 0 high CLOSED [RHEVM] [network labels] Failed to configure vm networks on host while changing its cluster. 2021-02-22 00:41:40 UTC
oVirt gerrit 24975 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never
oVirt gerrit 25459 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never
oVirt gerrit 25460 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never

Internal Links: 1064953

Description Martin Pavlik 2014-02-14 08:48:27 UTC
Created attachment 863178 [details]
logs from host

Description of problem:
This bug originated from bug 1064953 and it was raised to focus on the issue with incorrect presentation of the network configuration from Setup Host Networks dialog

for detailed description see reproduction steps

Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.7.beta2.el6 

How reproducible:
100%

Steps to Reproduce:
1. Define Data Center with two clusters: CL1 and CL2
2. Create network bridged NET1 with label lb_1 attached ONLY to cluster CL1
3. Create network bridged NET2 with label lb_1 attached ONLY to cluster CL2
4. add host A to CL1 with interface (other than ovirtmgmt) marked lb_1
5. Move host A from Cluster CL1 to Cluster CL2

Actual results:
The setup networks dialog presents the network configuration incorrectly. The NET2 network is never configured on the host, therefore it should never present that network as configured on the host.

Expected results:
host is moved from CL1 to CL2 and network on interface labeled lb_1 is reconfigured from NET1 to NET2 properly on the host and after proper configuration on the host it is presented in Setup Host Networks dialog

Additional info:


2014-02-13 15:29:25,004 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp--127.0.0.1-8702-5) [31c51424] Correlation ID: null, Call Stack: null, Custom Event ID: -1, Message: Failed to configure networks on host dell-05 while changing its cluster.

Comment 1 Martin Pavlik 2014-02-14 08:49:09 UTC
Created attachment 863179 [details]
logs from engine

Comment 2 Meni Yakove 2014-03-16 14:29:11 UTC
rhevm-3.4.0-0.5.master.el6ev.noarch

Comment 3 Sandro Bonazzola 2014-03-31 12:23:47 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.