Bug 106637 - crash if cancel activate USB modem connection
Summary: crash if cancel activate USB modem connection
Status: CLOSED DUPLICATE of bug 103421
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-config-network   
(Show other bugs)
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-08 23:41 UTC by John Reiser
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:59:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
saved from python crash dialog (1.99 KB, text/plain)
2003-10-08 23:43 UTC, John Reiser
no flags Details
another saved from python crash dialog (1.99 KB, text/plain)
2003-10-08 23:43 UTC, John Reiser
no flags Details

Description John Reiser 2003-10-08 23:41:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003

Description of problem:
If I try to Activate a USB modem connection using redhat-config-network, but
Cancel because it is taking too long (45 seconds and counting), then I see a
python crash dialog.  [The reason why dialing takes so long is that the phone
number was specified as 1+10D when only 10D is allowed, and so the ILEC gives
the S-I-T tones and a voice message, which the modem ignores. I discovered this
by changing the Init3 string in /etc/wvdial.conf from ATM0 to ATM1.]

Version-Release number of selected component (if applicable):
redhat-config-network-1.3.6

How reproducible:
Always

Steps to Reproduce:
1. Configure new USB modem connection (the very first one) using the patch given
in bug #100503. [Active ethernet connection also exists.]
2. Reboot.
3. Use RedHat > System Settings > Network to invoke redhat-config-network,
select the Modem device, and click on the Activate green arrow.  Wait a while
for dialing, answering, S-I-T tone, voice message, etc; click on Cancel in the
topmost dialog.
    

Actual Results:  Python crash dialog.  I will attach the saved file.

Expected Results:  Modem quits dialing, hangs up, resets (ATZ); no crash.

Additional info:

Comment 1 John Reiser 2003-10-08 23:43:04 UTC
Created attachment 95032 [details]
saved from python crash dialog

Comment 2 John Reiser 2003-10-08 23:43:46 UTC
Created attachment 95033 [details]
another saved from python crash dialog

Comment 3 Harald Hoyer 2003-10-09 14:59:31 UTC

*** This bug has been marked as a duplicate of 103421 ***

Comment 4 Red Hat Bugzilla 2006-02-21 18:59:02 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.