Bug 1066489 - Event list not updating when events happen.
Summary: Event list not updating when events happen.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.4.0
Assignee: Alexander Wels
QA Contact: Martin Pavlik
URL:
Whiteboard: ux
: 1066610 1066979 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-18 14:12 UTC by Alexander Wels
Modified: 2014-03-31 12:29 UTC (History)
12 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:29:44 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24409 0 None None None Never
oVirt gerrit 24835 0 None MERGED webadmin: revert refresh synchornization Never

Description Alexander Wels 2014-02-18 14:12:53 UTC
Description of problem:
We recently introduced code to quickly update events/models after an action or if new events arrive. Right after beta2 was released a patch was introduced that broke the updates of events. So for instance if you start a VM the grid will update but the event list will not indicate that the VM was started.

Version-Release number of selected component (if applicable):
3.4-beta2+

How reproducible:
Do any action that will generate an event, for instance start a VM, connect a console to a VM. Note the events at the bottom of the screen do not update.

Steps to Reproduce:
1.
2.
3.

Actual results:
Event list never updates.

Expected results:
Event list updates when actions happen.

Additional info:

Comment 1 Einav Cohen 2014-02-18 20:01:10 UTC
*** Bug 1066610 has been marked as a duplicate of this bug. ***

Comment 2 Einav Cohen 2014-02-19 15:41:33 UTC
*** Bug 1066979 has been marked as a duplicate of this bug. ***

Comment 3 Sandro Bonazzola 2014-02-24 08:17:21 UTC
This bug is blocking 3.4.0 final release. ETA for fixing it?

Comment 4 Alexander Wels 2014-02-24 12:53:16 UTC
The fix was merged the 23rd. Marking this as modified.

Comment 5 Sandro Bonazzola 2014-03-03 14:40:28 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 6 Martin Pavlik 2014-03-03 15:39:26 UTC
verified

Comment 7 Sandro Bonazzola 2014-03-31 12:29:44 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.