Bug 106669 - RHN hardware description erroneously displays 127.0.0.1 as the IP address
RHN hardware description erroneously displays 127.0.0.1 as the IP address
Status: CLOSED DUPLICATE of bug 457953
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools (Show other bugs)
5.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Pradeep Kilambi
Jan Hutař
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-09 08:29 EDT by Christian Rose
Modified: 2013-02-26 19:49 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-20 15:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
A screenshot of the problem (2.59 KB, image/png)
2003-10-09 08:30 EDT, Christian Rose
no flags Details

  None (edit)
Description Christian Rose 2003-10-09 08:29:27 EDT
We have a machine with two network interfaces, eth0 and eth1.

The problem is that the RHN web interface seems to be unable to decide what of
the IP addresses associated with the different interfaces should be displayed as
the IP address of the machine. Instead it displays 127.0.0.1 as the IP address
of the machine.

I would suggest that the RHN hardware detection should parse what interface is
the GATEWAYDEV (in this case eth0) and use that address as the machine's IP address.
Comment 1 Christian Rose 2003-10-09 08:30:59 EDT
Created attachment 95069 [details]
A screenshot of the problem

You can see the problem in the "IP Address" section in the upper half of this
screenshot.
Comment 2 Bill C. Riemers 2008-03-04 16:25:44 EST
This problem needs to be resolved within rhn_register.
Comment 3 Mike Orazi 2008-10-21 03:31:27 EDT
Prad,

Can you take a look?
Comment 5 Clifford Perry 2009-02-20 15:37:26 EST
Hi the Red Hat Enterprise Linux 5.3 release should have resolved this issue. I am closing this out as a duplicate of bug 457953. 

Regards,
Cliff

*** This bug has been marked as a duplicate of bug 457953 ***

Note You need to log in before you can comment on or make changes to this bug.