Bug 106679 - Evolution crashes just reading mail
Summary: Evolution crashes just reading mail
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-09 14:43 UTC by Thomas J. Baker
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2004-05-19 18:48:31 UTC
Type: ---


Attachments (Terms of Use)
crash traceback saved from bugzilla (10.58 KB, text/plain)
2003-10-09 18:36 UTC, Thomas J. Baker
no flags Details
traceback with a local folder (10.59 KB, text/plain)
2003-10-09 20:13 UTC, Thomas J. Baker
no flags Details
traceback reading from an imap folder (7.68 KB, text/plain)
2003-10-10 15:28 UTC, Thomas J. Baker
no flags Details

Description Thomas J. Baker 2003-10-09 14:43:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031003
Galeon/1.3.9

Description of problem:
Evolution periodically crashes just reading email. For instance, I filter all
email for fedora into a single folder. While reading through that folder, using
the preview pane, and using delete and down arrow to navigate, evolution will
crash. It's not consistent but it happens several times a day. The bugzilla
crash log comes up but the traceback doesn't look too useful due to missing
debug symbols. Is there an easy way to get the evolution-debuginfo or should I
just rebuild the src rpm?

Version-Release number of selected component (if applicable):
evolution-1.4.5-2

How reproducible:
Didn't try


Additional info:

I'm using the 2.6.0-0.test6.1.47smp kernel until I can get the later ones to
work the the nvidia driver. (I need the nvidia driver to support my dualhead setup.)

Comment 1 Jeremy Katz 2003-10-09 15:19:30 UTC
Does the new ORBit2 at http://people.redhat.com/~katzj/ORBit2/ help?

Comment 2 Thomas J. Baker 2003-10-09 15:22:48 UTC
No. I was experiencing all sorts of hangs but the ORBit update fixed those. This
is a real crash. Next time it happens, I'll include the traceback info to see if
it helps at all.

Comment 3 Jeremy Katz 2003-10-09 15:36:11 UTC
Yeah, just attach it without symbols... if it looks like something new, I'll
find somewhere with space for debuginfo pcakages since we still haven't gotten
them up anywhere :/

Comment 4 Thomas J. Baker 2003-10-09 18:36:10 UTC
Created attachment 95082 [details]
crash traceback saved from bugzilla

Here a an example traceback from a crash.

Comment 5 Thomas J. Baker 2003-10-09 20:13:57 UTC
Created attachment 95084 [details]
traceback with a local folder 

This trace is for a local folder. The previous one was for an imap folder. The
crash occurs similiarly, just reading email.

Comment 6 Jeremy Katz 2003-10-10 00:22:29 UTC
Hmm... is there a specific mail it always crashes on?  What accessibility type
things do you have enabled?

Also, -debuginfo available from http://linuxpower.org/~katzj/evo-debug/

Comment 7 Thomas J. Baker 2003-10-10 15:28:52 UTC
Created attachment 95104 [details]
traceback reading from an imap folder

First crash of the day with the debug modules installed. I was accessing an
imap folder this time. I'm obsoleting the first attachment as this is the same
with the debug info.

Comment 8 Thomas J. Baker 2003-10-10 15:31:27 UTC
These crashes are not mail message specific. After evo crashes, I restart it and
read the same message it crashed on without any problems. 

Comment 9 Jeremy Katz 2003-10-13 21:15:49 UTC
What versions of gtk2 and atk do you have installed?  

Do you have anything enabled under Preferences->Accessibility (for the entire
desktop)?

Comment 10 Thomas J. Baker 2003-10-13 22:55:36 UTC
gtk2-2.2.4-3.1, atk-1.4.0-1

The only think enabled is "enable repeat keys".

Comment 11 Jeremy Katz 2003-10-16 19:50:30 UTC
Hmmm, I've been running with those accessiblity settings for several days now
without hitting this problem.

And it definitely looks to be in gtkhtml's a11y code from the backtrace.

Comment 12 Thomas J. Baker 2003-10-17 11:50:29 UTC
Maybe it's related to the Assisted Technology Support? I had the "Enable
Assitive Technologies" checked but not any of the sub options. When I got your
message about Accessibility, I turned this option off and have not had the crash
in a while. 

Comment 13 Dave Malcolm 2004-05-19 18:48:31 UTC
Looks like a duplicate of upstream bug:
http://bugzilla.ximian.com/show_bug.cgi?id=42867


Note You need to log in before you can comment on or make changes to this bug.