Bug 106721 - Prelink always does a full prelink after system reboot
Summary: Prelink always does a full prelink after system reboot
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: prelink   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-10-09 20:54 UTC by Davide Moretti
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 20:34:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2004:386 normal SHIPPED_LIVE Updated prelink package 2004-09-02 04:00:00 UTC

Description Davide Moretti 2003-10-09 20:54:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031008

Description of problem:
Since the file /var/run/prelink.full is deleted by rc init script at system
startup, prelink state information is not maintained during reboots so prelink
always does a full prelink the next time is run after the system is rebooted.

Version-Release number of selected component (if applicable):
prelink-0.3.0-7

How reproducible:
Always

Steps to Reproduce:
1. reboot :)


Actual Results:  the file /var/run/prelink.full is deleted

Expected Results:  it should be skipped during /var/run initial cleanup or
placed in another directory.

Additional info:

Comment 1 Bill Nottingham 2003-10-09 21:15:27 UTC
Using either /var/lib/misc/, or creating a /var/lib/prelink/ dir and using that
should be ok.

Comment 2 Jakub Jelinek 2003-10-09 22:28:58 UTC
Should be fixed in prelink-0.3.0-8.

Comment 3 Chris Ricker 2003-10-22 20:34:38 UTC
closing fixed, thanks

Comment 4 Jay Turner 2004-09-02 05:19:47 UTC
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-386.html



Note You need to log in before you can comment on or make changes to this bug.