Bug 1067502 - rebase linuxptp to 1.4
Summary: rebase linuxptp to 1.4
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: linuxptp
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: ---
Assignee: Miroslav Lichvar
QA Contact: Jimmy Pan
URL:
Whiteboard: rebase
Keywords: Rebase
Depends On:
Blocks: 1005342
TreeView+ depends on / blocked
 
Reported: 2014-02-20 14:46 UTC by Miroslav Lichvar
Modified: 2015-07-20 00:55 UTC (History)
4 users (show)

(edit)
Important: if this rebase instead contains *only bug fixes,* or *only enhancements*, select the correct option from the Doc Type drop-down list.

Rebase package(s) to version: 
1.4 (git snapshot from 20140318)
Highlights, important fixes, or notable enhancements: 
Added an adaptive servo based on linear regression (unlike PI servo, it doesn't need to be configured for good performance), included improvements for 802.1AS clocks, fixed bugs in delay measurement, added new configuration options, and other improvements and bugfixes.
Clone Of:
(edit)
Last Closed: 2014-10-14 07:03:52 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1491 normal SHIPPED_LIVE linuxptp bug fix and enhancement update 2014-10-14 01:28:25 UTC

Description Miroslav Lichvar 2014-02-20 14:46:56 UTC
Description of problem:
This is a proposal to rebase linuxptp to the new 1.4 release.

It fixes several important bugs and adds some new useful features. It fixes all currently open RHEL6 bugs for linuxptp (bug #1019121, bug #1016356, bug #1011022, bug #1004996).

Announcement with changelog:
http://sourceforge.net/mailarchive/message.php?msg_id=31978738

Comment 1 Jimmy Pan 2014-05-04 05:16:48 UTC
(In reply to Miroslav Lichvar from comment #0)
> Description of problem:
> This is a proposal to rebase linuxptp to the new 1.4 release.
> 
> It fixes several important bugs and adds some new useful features. It fixes
> all currently open RHEL6 bugs for linuxptp (bug #1019121, bug #1016356, bug
> #1011022, bug #1004996).
> 
> Announcement with changelog:
> http://sourceforge.net/mailarchive/message.php?msg_id=31978738

Hi Miroslav,

It seems the changelog cannot be opened because of 403.

BTW, do you have any suggestions what kind of tests we should do specifically for the update?

Comment 2 Miroslav Lichvar 2014-05-05 12:31:43 UTC
(In reply to Jimmy Pan from comment #1)
> It seems the changelog cannot be opened because of 403.

Here is a mirror: http://thread.gmane.org/gmane.comp.linux.ptp.devel/1784

> BTW, do you have any suggestions what kind of tests we should do
> specifically for the update?

Beside testing of the other bugs filed for linuxptp, which will be fixed by this rebase, I think it would be nice to test the new fast slewing of the system clock (10% instead of 500ppm) with ptp4l and SW time stamping or phc2sys.

I'm considering to rebase to a post-1.4 git snapshot (2b099cf) to include the new adaptive linreg servo.

BTW, I'll include in the package linuxptp-testsuite with clknetsim and run it in rpm %check to have better testing coverage.

Comment 5 errata-xmlrpc 2014-10-14 07:03:52 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1491.html


Note You need to log in before you can comment on or make changes to this bug.