This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 106757 - Looks for modules/perl code at wrong path
Looks for modules/perl code at wrong path
Status: CLOSED DUPLICATE of bug 90202
Product: Red Hat Raw Hide
Classification: Retired
Component: spamassassin (Show other bugs)
1.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Chip Turner
David Lawrence
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-10 07:17 EDT by Kim Bisgaard
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kim Bisgaard 2003-10-10 07:17:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020623
Debian/1.0.0-0.woody.1

Description of problem:
When starting spamd or spamassassin it is obvious that something is wrong in the
installation of spamassassin.


When looking in /usr/bin/spam{d,assasin} one can see that
"/usr/src/build/311525-i386/install/" should have been removed (substituted with "")

It is probably also a problem in other perl programs in this RPM.

When the above changes have been made, it works again.



Version-Release number of selected component (if applicable):
spamasssassin-2.60-2

How reproducible:
Always

Steps to Reproduce:
1. service spamassassin start
2. problem is evident

    

Actual Results:  Starting spamd: Can't locate Mail/SpamAssassin.pm in @INC (@INC
contains: ../lib
 /usr/src/build/311525-i386/install//usr/lib/perl5/vendor_perl/5.8.1 /usr/lib/pe
rl5/5.8.0/i386-linux-thread-multi /usr/lib/perl5/5.8.0 /usr/lib/perl5/site_perl/
5.8.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.0 /usr/lib/perl5/site
_perl /usr/lib/perl5/vendor_perl/5.8.0/i386-linux-thread-multi /usr/lib/perl5/ve
ndor_perl/5.8.0 /usr/lib/perl5/vendor_perl) at /usr/bin/spamd line 33.
BEGIN failed--compilation aborted at /usr/bin/spamd line 33.
                                                           [FAILED]

Additional info:
Comment 1 Miloslav Trmac 2003-10-10 11:39:06 EDT
This is a duplicate of 90202.
Comment 2 Miloslav Trmac 2004-07-14 21:42:58 EDT

*** This bug has been marked as a duplicate of 90202 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:03 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.