Bug 106784 - Cannot load i810_audio module for SiS7012 sound card on Clevo D27ES laptop
Summary: Cannot load i810_audio module for SiS7012 sound card on Clevo D27ES laptop
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On: 106809
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-10-10 15:48 UTC by Peter Lister
Modified: 2015-01-04 22:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-30 03:53:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Peter Lister 2003-10-10 15:48:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
This laptop has only a "Win95" or "ACPI" choice in the BIOS for assigning IRQs.
 Neither seems to improve matters.  I tried RH9, and then tried the RawHide
2.4.22 kit as it seems that this card would need ACPI support, which apparently
is improved since 2.4.20. 

I have tried with pci=biosirq on the command line as the syslog message
suggests, but there is no improvement.


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2087.nptl

How reproducible:
Always

Steps to Reproduce:
[root@localhost prl]# uname -a
Linux localhost.localdomain 2.4.22-1.2087.nptl #1 Sat Oct 4 09:42:49 EDT 2003
i686 i686 i386 GNU/Linux
[root@localhost prl]# cat /proc/cmdline
ro root=LABEL=/ hdc=ide-scsi pci=biosirq
[root@localhost prl]# /sbin/modprobe i810_audio
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/sound/i810_audio.o: init_module:
No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/sound/i810_audio.o: insmod
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/sound/i810_audio.o failed
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/sound/i810_audio.o: insmod
i810_audio failed
[root@localhost prl]# tail -5 /var/log/messages
Oct 10 16:31:07 localhost su(pam_unix)[5636]: session opened for user root by
prl(uid=500)
Oct 10 16:31:48 localhost kernel: Intel 810 + AC97 Audio, version 0.24, 09:50:10
Oct  4 2003
Oct 10 16:31:48 localhost kernel: PCI: No IRQ known for interrupt pin C of
device 00:02.7.
Oct 10 16:31:48 localhost kernel: i810: SiS 7012 found at IO 0x1800 and 0x1c00,
MEM 0x0000 and 0x0000, IRQ 0
Oct 10 16:31:48 localhost kernel: i810_audio: unable to allocate irq 0
[root@localhost prl]#



Additional info:

Comment 1 Peter Lister 2003-10-10 19:02:14 UTC
Some extra musings... based on some google and archived linux-kernel emails out
there, notably from Alan Cox - it's my belief that the i810_audio *should* work
for SiS 7012, so this isn't a gripe about the driver per se (though it appears
that AC has a low opinion of the 7012), but about the (possibly ACPI related)
IRQ issues.

Comment 2 Dave Jones 2003-10-11 12:57:25 UTC
Note that acpi is automatically disabled unless you boot with acpi=on



Note You need to log in before you can comment on or make changes to this bug.