This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 106809 - acpi=on required to run ACPI
acpi=on required to run ACPI
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: 106784
  Show dependency treegraph
 
Reported: 2003-10-10 15:53 EDT by Peter Lister
Modified: 2007-04-18 12:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-24 17:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lister 2003-10-10 15:53:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The acpi/* modules refuse to load, as described below. Other modules appear to
load fine. There is no relevant error text in dmesg or syslog.


Version-Release number of selected component (if applicable):
kernel-2.4.22-1.2087.nptl

How reproducible:
Always

Steps to Reproduce:
[root@localhost prl]# /sbin/modprobe battery


Actual Results:  /lib/modules/2.4.22-1.2087.nptl/kernel/drivers/acpi/battery.o:
init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including
invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/acpi/battery.o: insmod
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/acpi/battery.o failed
/lib/modules/2.4.22-1.2087.nptl/kernel/drivers/acpi/battery.o: insmod battery failed
[root@localhost prl]#



Additional info:

There are no errors from depmod -a

When I cut an RPM of the kernel 2.4.22-20.9 kit, with APM disabled and ACPI
enabled, the corresponding ospm* modules built and could be loaded with modprobe
just fine (whether they worked is another matter, but they could be loaded).

I note that I'm having trouble with the i810_audio driver [Bug 106784], which
might be ACPI related, so it occurs to me to wonder if there is some more
general ACPI issue on this hardware.
Comment 1 Bill Nottingham 2003-10-10 16:02:03 EDT
Did you boot with acpi=on?
Comment 2 Daryll 2003-10-16 15:27:50 EDT
Same problem. I can't load battery or ac modules. It worked with version 2061
and started failing with kernel versions after that. This is an HP Pacillion Ze
laptop.
Comment 3 Peter Lister 2003-10-16 16:14:12 EDT
Sigh. No, I've now set up acpi=on and it all works (so does i810_audio, bug ),
so I feel a bit stupid.

In my defence, I *did* try to search for similar problems, but as I saw quite a
few ACPI messages on start, it wasn't obvious to me that ACPI was off by
default. The modules don't fail with a helpful reason...

So  I guess you can close this as a dup, but hopefully some others will find
this particular entry before wasting a day or two...
Comment 4 Peter Lister 2003-10-16 16:15:11 EDT
And bug 106784.
Comment 5 Daryll 2003-10-16 16:31:31 EDT
acpi=on works for me. Helps if you put it on the correct line in your grub.conf. :(

Note You need to log in before you can comment on or make changes to this bug.