Bug 1067928 - [webadmin] [network labels] emphasize unconfigured interface in Setup Host Networks dialog
Summary: [webadmin] [network labels] emphasize unconfigured interface in Setup Host Ne...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: ---
: 3.4.0
Assignee: Alona Kaplan
QA Contact: Martin Pavlik
URL:
Whiteboard: network
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-21 12:06 UTC by Martin Pavlik
Modified: 2014-04-01 05:01 UTC (History)
11 users (show)

Fixed In Version: ovirt-3.4.0-ga
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:28:34 UTC
oVirt Team: ---


Attachments (Terms of Use)
screenshot 1 (166.20 KB, image/png)
2014-02-21 12:06 UTC, Martin Pavlik
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 24975 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never
oVirt gerrit 25459 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never
oVirt gerrit 25460 0 None MERGED webadmin: [Labels] SetupNetwork emphasize unconfigured interface Never
oVirt gerrit 25477 0 None MERGED webadmin: Labeled Networks with vlan shown outside the label group Never

Description Martin Pavlik 2014-02-21 12:06:56 UTC
Created attachment 865939 [details]
screenshot 1

Description of problem:

if user creates two networks with the same label which cannot coexist on labeled host interface. Second network is not configured on the host and appropriate event log is displayed. However in Setup Host Networks dialog the second unconfigured network looks like it is attached (see screenshot) just fine. 


Version-Release number of selected component (if applicable):
oVirt Engine Version: 3.4.0-0.11.beta3.el6 

How reproducible:
100%

Steps to Reproduce:
1) create bridged network NET_bridged with label lb_bridged attached to Cluster
2) host with interface labeled lb_bridged
3) create bridged network NET2_bridged with label lb_bridged attached to Cluster

Actual results:
network which is in fact not attached to interface looks like attached in Setup Networks dialog

Expected results:
let the user clearly know that network is not attached to the interface and he is not supposed to do this

for example by changing the unconfigured network to red color with appropriate tool tip

Additional info:

Comment 1 Lior Vernia 2014-02-23 11:18:52 UTC
Somewhat similar to Bug 1065270, sounds to me like both could be solved in a single patch by initially displaying what's actually configured on the host.

Comment 2 Sandro Bonazzola 2014-03-31 12:28:34 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.