Bug 106824 - vim should require gtk2-devel if withgtk2=1, not gtk+-devel
Summary: vim should require gtk2-devel if withgtk2=1, not gtk+-devel
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: vim   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-10 23:45 UTC by Max Kanat-Alexander
Modified: 2007-04-18 16:58 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-21 14:28:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Max Kanat-Alexander 2003-10-10 23:45:54 UTC
Description of problem:
This is just a BuildRequires issue for the vim SRPM --

For vim-X11, it should be:

%if %{withgtk2}
BuildRequires: gtk2-devel
%else
BuildRequires: gtk+-devel
%endif

Right now it's just BuildRequires: gtk+-devel

Version-Release number of selected component (if applicable):
vim-6.2.98-1.1

How reproducible:
Always

Steps to Reproduce:
1. Remove gtk+-devel from the system.
2. Attempt to build vim SRPM in Rawhide.

Actual Results:  Rpmbuild claims that it can't proceed because of a missing
dependency.

With --nodeps, the package compiles, installs, and runs perfectly.

Expected Results:  Package compiles without --nodeps being required.


Note You need to log in before you can comment on or make changes to this bug.