Bug 106841 - Network Control Device crashes when dial-up ISP has a busy signal for external serial modem
Network Control Device crashes when dial-up ISP has a busy signal for externa...
Status: CLOSED DUPLICATE of bug 103421
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-11 13:07 EDT by Christopher Bass
Modified: 2007-04-18 12:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christopher Bass 2003-10-11 13:07:42 EDT
Description of problem:
when Network Control Device is used to run an external serial modem (USR
Courier) within Gnome, and the dial-up ISP's phone line is busy, then Network
Control Device crashes.

Version-Release number of selected component (if applicable):
1.2.15

How reproducible:
Always

Steps to Reproduce:
1. started the Network Control Device on the control panel of Gnome
2. highlighted the ppp0 device and clicked Activate
3. computer dials out
4. if the dial-up ISP is busy, the status menu on Network Control Device doesn't
change and doesn't go away
5. if cancel is clicked or the window closed, Network Control Device crashes

    
Actual results:


Expected results:


Additional info:
Comment 1 Christopher Bass 2003-10-11 13:12:55 EDT
Component: redhat-config-network
Version: 1.2.15
Summary: TB79414994 GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1]
Operation not permitted
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 184, in on_activateButton_clicked
    (ret, msg) = dev.activate()
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 376, in activate
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 420, in generic_run_dialog
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 523, in gui_run_dialog
OSError: [Errno 1] Operation not permitted

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x8661ba4>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x86cf924>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x857c784>
cancelbutton: <gtk.Button object (GtkButton) at 0x8661c54>
command: /usr/sbin/usernetctl
argv: ['/usr/sbin/usernetctl', 'ppp0', 'up']
searchPath: 0
label: Activating network device IU, please wait...
lbl: <gtk.Label object (GtkLabel) at 0x86cf7bc>
select: <module 'select' from '/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x865e47c>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x86ced84>
errlabel: Cannot activate network device IU!

fdout: []
root: /
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0x86d116c>
write: 4
read: 3
s: 1
childpid: 2366
closefd: -1
dialog: None
rc: 
title: redhat-config-network:

Network device activating...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x8661c24>
Comment 2 Harald Hoyer 2003-10-13 06:25:42 EDT

*** This bug has been marked as a duplicate of 103421 ***
Comment 3 Red Hat Bugzilla 2006-02-21 13:59:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.