This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 106854 - Loading default keymap (Dvorak): failed
Loading default keymap (Dvorak): failed
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
rawhide
athlon Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-12 04:28 EDT by Paul
Modified: 2014-03-16 22:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.41-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-22 15:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Paul 2003-10-12 04:28:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I chose Dvorak as my keyboard layout.  When booting (nogui) I get the message
"Loading default keymap (Dvorak): failed".  Even so, the keymap is correct after
booting.  If I specify the absolute path to the keymap file, the message changes
from "failed" to "OK".

Version-Release number of selected component (if applicable):
initscripts-7.34-1

How reproducible:
Always

Steps to Reproduce:
1. Choose Dvorak as your keyboard layout.
2. Reboot.


Actual Results:  "Loading default keymap (Dvorak): failed"
Yet, the kaymapping is correct.

Expected Results:  "Loading default keymap (Dvorak): OK"

Additional info:

My keyboard is a regular US keyboard with the keycaps moved to match the Dvorak
layout.

Under Red Hat 9.0 I have to use the absolute path to the Dvorak keymap file or I
would end up with the US keymap.  The real problem seems to have been corrected
in Fedora Test 2, but the "failed" message still appears.
Comment 1 Bill Nottingham 2003-10-13 15:59:31 EDT
What happens if you change rc.sysinit from:

  if [ -n "$KEYTABLE" -a -d "/lib/kbd/keymaps" ]; then
     KEYMAP=$KEYTABLE
  fi

to:

  if [ -n "$KEYTABLE" -a -d "/lib/kbd/keymaps" ]; then
     KEYMAP=$KEYTABLE.map
  fi

?
Comment 2 Paul 2003-10-22 00:23:02 EDT
I'm sorry.  I'm running my system headless right now and I haven't been able to
get the serial console to show boot messages.  In other words, I haven't been
able to try the suggested script mod.
Comment 3 Bill Nottingham 2003-10-22 15:25:48 EDT
This change works for me in testing. Will be fixed in 7.41-1.
Comment 4 Jay Turner 2004-01-16 12:19:02 EST
An errata has been issued which should help the problem described in this bug report. 
This report is therefore being closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, please follow the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-328.html

Note You need to log in before you can comment on or make changes to this bug.