Bug 1068740 - pxeboot of LiveCD fails to loopmount iso from initramfs
Summary: pxeboot of LiveCD fails to loopmount iso from initramfs
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1067520
TreeView+ depends on / blocked
 
Reported: 2014-02-21 19:25 UTC by Henrik Nordström
Modified: 2014-05-08 08:45 UTC (History)
4 users (show)

Fixed In Version: dracut-037-10.git20140402.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-06 02:37:45 UTC


Attachments (Terms of Use)

Description Henrik Nordström 2014-02-21 19:25:27 UTC
Description of problem:

trying to pxeboot LiveCD image created by livecd-iso-to-pxeboot fails to mount root

Version-Release number of selected component (if applicable):

dracut-034-64.git20131205.fc20.1.x86_64 and also tried Fedora-Live-Desktop-x86_64-20-1.iso

How reproducible:

always

Steps to Reproduce:
1. livecd-iso-to-pxeboot Fedora-Live-Desktop-x86_64-20-1.iso
2. network boot the generated image
3.

Actual results:

drops to dracut shell after long delay waiting for rootfs.

Expected results:

Fedora Live boot

Additional info:

Actually trying to produce our own pxeboot live image using current Fedora 20 and experienced the problem. Then tried with official LiveCD and same problem.

If I add the squashfs.img file to to the initramfs instead of the iso and load that as root=live:/squashfs.img then it boots kind of.. except that it's not the right rootfs for a LiveCD.

The iso file is verified to be present at expected path in the initramfs.

Kernel command line:

rootflags=loop initrd=initrd0.img root=live:/Fedora-Live-Desktop-x86_64-20-1.iso rootfstype=auto ro rd.live.image quiet rhgb rd.luks=0 rd.md=0 rd.dm=0

Comment 1 Henrik Nordström 2014-02-24 09:52:20 UTC
Works fine in rawhide, and judging from dracut commit history this was fixed in 036 by this commit: http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=c84618d7ac5cf87c6efaaca00e52f69dcff954e1

loop is a module in fedora.

Comment 2 Henrik Nordström 2014-02-24 09:54:27 UTC
Err, don't know what happened there, wrong git url. This one:

http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=ba9368fa4fedda0f72d84f910d01d7da201405a3

Comment 3 Fabian Deutsch 2014-03-18 15:22:11 UTC
Would be great if a fix for this can appear in Fedora 20, as oVirt Node PXE boot is blocked by this.

Comment 4 Paul Stauffer 2014-03-28 15:11:01 UTC
FWIW, I have confirmed that the same procedure works fine with F19, so this is a regression in F20.

Comment 5 Fedora Update System 2014-04-02 08:57:33 UTC
dracut-037-10.git20140402.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-037-10.git20140402.fc20

Comment 6 Fedora Update System 2014-04-03 04:04:01 UTC
Package dracut-037-10.git20140402.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-037-10.git20140402.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4704/dracut-037-10.git20140402.fc20
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2014-04-06 02:37:45 UTC
dracut-037-10.git20140402.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.