Bug 1069151 - Override previous export of same template fail
Summary: Override previous export of same template fail
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 3.4.0
Assignee: Tal Nisan
QA Contact: Ilanit Stein
URL:
Whiteboard: storage
: 1057764 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-24 10:47 UTC by Ilanit Stein
Modified: 2016-02-10 17:56 UTC (History)
8 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:23:55 UTC
oVirt Team: Storage


Attachments (Terms of Use)
logs (1.35 MB, application/x-bzip2)
2014-02-24 10:50 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 25144 0 None MERGED core: Fix a bug in exporting template with force override Never
oVirt gerrit 25145 0 None MERGED core: Fix a bug in exporting template with force override Never

Description Ilanit Stein 2014-02-24 10:47:24 UTC
Description of problem:
This is a regression in VM test, since version: ovirt-engine-3.4.0-0.5.beta1.el6.noarch.
Override trial of a template in export domain, fail on (engine.log):
[org.ovirt.engine.api.restapi.resource.AbstractBackendResource] (ajp--127.0.0.1-8702-9) Operation Failed: [Cannot export Template. The Storage Domain already contains the target disk(s).]

The REST Request, which include exclusive = 'true':
2014-02-23 15:55:27,861 - MainThread - templates - DEBUG - Action request content is --  url:/api/templates/aa89a256-0d02-43a4-bf5e-5a5953138044/export body:<action>
    <async>false</async>
    <grace_period>
        <expiry>10</expiry>
    </grace_period>
    <storage_domain>
        <name>ExportDomainRest</name>
    </storage_domain>
    <exclusive>true</exclusive>
</action>

Version-Release number of selected component (if applicable):
This problem exists for some time. We see it now on released:
ovirt-engine-3.4.0-0.11.beta3.el6.noarch,
and it exists at least from ovirt-engine-3.4.0-0.5.beta1.el6.noarch.
It is also seen on rhevm-3.4.0-0.2.1959.cc71493.master.el6evart-1.0.4-6v34

How reproducible:
100% - At each VM test run on CI\QE.

Additional info:
vms test run on QE for Ovirt 3.4:
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Compute/view/3.4-git/view/Virt/job/3.4-git-compute-virt-reg_vms-rest-nfs/36/
vms test run on CI for rhevm 3.4:
http://jenkins-ci.eng.lab.tlv.redhat.com/job/rhevm_3.4_automation_coretools_two_hosts_restapi_vms_nfs_rest_factory/

Comment 1 Ilanit Stein 2014-02-24 10:50:32 UTC
Created attachment 866928 [details]
logs

Comment 2 Roy Golan 2014-02-25 15:24:22 UTC
moving to whiteboard storage - the CDA at ExportVmTemplate checks if that disk exist and isn't relating to forceOverride at all

flow: 
ExportVmTemplate.canDo
ExportVmTemplate:138 super.canDoAction
MoveOrCopyTemplateCommand:132 checkIfDisksExist(getTemplateDisks())
MoveOrCopyTemplateCommand:257 ->

if (imagesOnStorageDomain.contains(disk.getId())) {
                addCanDoActionMessage(VdcBllMessages.ACTION_TYPE_FAILED_STORAGE_DOMAIN_ALREADY_CONTAINS_DISK);
                return false;
            }

Comment 3 Sandro Bonazzola 2014-03-03 14:40:23 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 5 Sandro Bonazzola 2014-03-31 12:23:55 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released

Comment 6 Maor 2014-04-27 08:25:57 UTC
*** Bug 1057764 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.