Bug 1069299 - gnome-shell becomes unresponsive
Summary: gnome-shell becomes unresponsive
Keywords:
Status: CLOSED DUPLICATE of bug 960381
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-24 17:08 UTC by Radist Morse
Modified: 2016-05-06 16:11 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-01 20:08:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 712311 None None None 2019-05-17 13:20:43 UTC

Description Radist Morse 2014-02-24 17:08:52 UTC
gnome-shell totally freezes at random time, usually once per several hours. Mouse is moving, but everything on screen is totally unresponsive. I can still switch to tty2, and if I switch back I see only a mouse pointer on the black screen. killall -9 gnome-shell helps.

The journal is flooded with these messages

фев 24 17:48:58 ******* gnome-session[1314]: (gnome-shell:1467): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (manager)' failed
фев 24 17:48:58 ******* gnome-session[1314]: Предупреждение менеджера окон: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
фев 24 17:48:58 ******* gnome-session[1314]: Предупреждение менеджера окон: Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed

over and over again (like, dosens per second), until you kill gnome-shell.

Extensions I use: Media player indicator, System monitor, User themes, Weather

I currently have gnome-shell.x86_64-3.10.3-7.fc20, but the problem started long ago.

Comment 1 Radist Morse 2014-02-25 15:14:59 UTC
Updated to 3.10.4-1.fc20, no change.

Comment 2 Hugo 2014-03-22 00:00:59 UTC
I have the same symptoms and the same logs.
Only the GUI seems to be frozen, music keeps on playing, and I can switch to a tty.

Once I have been patient enough not to kill gnome-shell immediately. And it recovers after less than 10 seconds.
Then the logs keeps on being flooded with the same message, even though gnome shell reponds normally.




mars 21 23:52:27 ******* gnome-session[3117]: Gjs-Message: JS LOG: AppOutputStreamSlider
mars 21 23:52:27 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:52:27 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:52:27 ******* gnome-session[3117]: (gnome-shell:3264): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (
mars 21 23:52:27 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:52:27 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:52:27 ******* gnome-session[3117]: (gnome-shell:3264): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (
mars 21 23:52:27 ******* gnome-session[3117]: Gjs-Message: JS LOG: AppOutputStreamSlider
mars 21 23:52:27 ******* gnome-session[3117]: fixme:win:FlashWindowEx 0x33bbc4
mars 21 23:52:00 ******* dbus-daemon[2115]: dbus[2115]: [system] Activation 
via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.
mars 21 23:52:00 ******* dbus[2115]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.ModemManager1.service': Unit dbus-org.freedesktop.ModemMa
mars 21 23:52:00 ******* dbus[2115]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.ModemManager1.service'
mars 21 23:52:00 ******* dbus-daemon[2115]: dbus[2115]: [system] Activating via systemd: service name='org.freedesktop.ModemManager1' unit='dbus-org.freedesktop.Mod
mars 21 23:51:56 ******* gnome-session[3117]: fixme:win:FlashWindowEx 0x33c804
mars 21 23:51:55 ******* gnome-session[3117]: Gjs-Message: JS LOG: AppOutputStreamSlider
mars 21 23:51:55 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:51:55 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:51:55 ******* gnome-session[3117]: (gnome-shell:3264): Clutter-CRITICAL **: clutter_layout_manager_get_child_meta: assertion 'CLUTTER_IS_LAYOUT_MANAGER (
mars 21 23:51:55 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed
mars 21 23:51:55 ******* gnome-session[3117]: Avertissement du gestionnaire de fenêtres : Log level 8: g_object_set: assertion 'G_IS_OBJECT (object)' failed

Comment 3 Pacho Ramos 2014-04-19 16:59:49 UTC
Looks like upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=712311

Sadly without solution :(

Comment 4 Stephen Tweedie 2014-05-14 09:34:19 UTC
Any update on this, btw?  I'm seeing it 3 or 4 times a day on f20 latest stable updates, it is a serious nuisance...

Seeing as I seem to be able to reproduce it so easily, let me know if there's any debugging I can add.  Thanks!

Comment 5 Brian Vogel 2014-05-29 14:18:26 UTC
Oddly adding "fs.inotify.max_user_watches=100000" into /etc/sysctl.d/inotify.conf reduced this issue to a usable state.

Comment 6 Brian Vogel 2014-05-29 14:21:48 UTC
Dump of same issue https://bugzilla.redhat.com/show_bug.cgi?id=1096873

Comment 7 Christopher Beland 2014-12-29 20:03:44 UTC
Bug 960381 leads me to believe that the Gnome Weather extension might be causing trouble.  Does disabling that fix this for you?

Comment 8 Radist Morse 2014-12-29 21:09:10 UTC
I did have that weather extention enabled back then, but I never encountered memory leakage. 100% CPU was probably there (I can't tell for sure, but CPU fan jumped up every time gnome-shell hanged).

I didn't encounter this problem since I moved to F21/Gnome 3.14, but I didn't install weather extension, so I don't know what was the cause.

I installed it just now, will tell if I encounter the bug again.

Comment 9 Radist Morse 2014-12-31 20:11:14 UTC
Just got this bug again. g-s was using 100% cpu, ate about 1-1,5 GB ram and was spamming in the journal.

It behaved sligtly different after switching to tty2 and back, though. Still, we can conclude that the weather extension is indeed responsible.

Comment 10 Christopher Beland 2015-01-01 20:08:21 UTC
Great; thanks for re-testing!

*** This bug has been marked as a duplicate of bug 960381 ***


Note You need to log in before you can comment on or make changes to this bug.