Bug 106933 - less is slow in gnome-terminal and leaves artifacts using PageUp
less is slow in gnome-terminal and leaves artifacts using PageUp
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: vte (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 15:53 EDT by Forrest
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 23:06:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Forrest 2003-10-13 15:53:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When in less or man, using PageUp will leave artifacts as it scrolls up.  It is
also much slower than PageDown.

Version-Release number of selected component (if applicable):
less-378-11.1

How reproducible:
Always

Steps to Reproduce:
1.  Use less or man to read something
2.  Use PageDown to scroll down
3.  Use PageUp to scroll up to see the difference
    

Actual Results:  PageDown works, and PageUp causes artifacts until it reaches
the bottom of the page, and then refreshes.  It is also slower.

Expected Results:  PageUp should work like PageDown

Additional info:
Comment 1 Bill Nottingham 2003-10-14 00:59:58 EDT
Is this in a particular terminal type, or all types?
Comment 2 Forrest 2003-10-14 23:47:26 EDT
This is in gnome-terminal.  I'll try some other terminals and see if it acts
similarly.
Comment 3 Forrest 2003-10-15 12:59:14 EDT
This only affects gnome-terminal
Comment 4 Vic Gedris 2003-11-09 13:55:47 EST
This sounds an aweful lot like the bug I reported for Gnome-Terminal
in Redhat 9 (still hasn't been fixed in FC1):
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=103925

I've just been noticing it in a different place:  When I'm running
mutt under a screen session.  I don't get the same problem when
running "less".

I can provide more details if requested.  I'd like to see this one
solved.  It only happens under gnome-terminal.  Others (xterm,
multi-gnome-terminal, etc.) work fine.
Comment 5 Forrest 2004-02-17 15:31:32 EST
Still happens in FC2-test1
Comment 6 Thomas M Steenholdt 2004-03-16 15:50:32 EST
This may very well be the same problem i've been seeing - Here the
most convinsible app to show the problem is vim scrolling up/down in a
file.
System uses 100% CPU X about 97% gnome-terminal about 3%. I know that
due to the nature of X it will often be blamed for high loads when
it's actually an app that's the problem - please let me know how to
split the results if required!
Comment 7 Thomas M Steenholdt 2004-03-16 16:46:57 EST
This actually looks an awful lot like this issue that's been discussed
on bugzilla.gnome.org a while ago! It does not look like there is a
resolution!

http://bugzilla.gnome.org/show_bug.cgi?id=96879

please move bug to vte if you think this is correct!
Comment 8 Forrest 2004-04-08 14:10:06 EDT
Thanks for the link.  I also see that Bug #85874 is similar, and Havoc
said that it was a vte problem,  so I'll try to change it to vte.
Comment 9 Egmont Koblinger 2004-11-09 07:11:09 EST
Please see
http://bugzilla.gnome.org/show_bug.cgi?id=156935
for a more detailed description of the same problem.
Comment 10 Egmont Koblinger 2005-01-15 05:49:13 EST
See also
http://bugzilla.gnome.org/show_bug.cgi?id=164153
Comment 11 Warren Togami 2005-09-08 23:06:15 EDT
http://bugzilla.gnome.org/show_bug.cgi?id=120401 claims this is fixed in
vte-0.11.14, which is now pushed into FC3, FC4 and FC5.
Comment 12 Thomas M Steenholdt 2005-09-09 05:31:57 EDT
Seems to do the trick for me regarding the page-up lag in less at least...

gnome-terminal is still very slow compared to xterm and konsole...

in a maximized gnome-terminal try this:

time find /usr -print0

on my System it takes ~ 55 seconds to complete

in xterm and konsole, results for both is ~ 16-17 secs

Note You need to log in before you can comment on or make changes to this bug.