Bug 1069499 - gnome-session-properties does not save modified start-up jobs
Summary: gnome-session-properties does not save modified start-up jobs
Keywords:
Status: CLOSED DUPLICATE of bug 1069503
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-session
Version: 6.6
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 07:16 UTC by Assen Totin
Modified: 2014-06-23 00:00 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-23 00:00:24 UTC


Attachments (Terms of Use)

Description Assen Totin 2014-02-25 07:16:37 UTC
Description of problem:
gnome-session-properties fails to save modifications to command line in a start-up job. 


Version-Release number of selected component (if applicable):
gnome-session-2.28.0-18

How reproducible:
Every time.

Steps to Reproduce:
1. Open gnome-session-properties. Create a new start-up (fill all 3 fields) job and save it. Close gnome-session-properties.
2. Re-open gnome-session-properties. Open the job created in step 1. Verify it has the same command line as entered at step 1. Modify the command line and save the chages. Close gnome-session-properties.
3. Re-open gnome-session-properties. Open the job created at step 1. The command line is still the one, set in step 1 (and not the one, modified in step 2).

Actual results:
Modification to comamnd line are not saved.

Expected results:
Modification to comamnd line should be saved.

Additional info:
There are other issues with this component too, e.g. if you delete a job and try to create the same, it will not be saved at all. This is rather confusing and needs attention.

Comment 2 Ray Strode [halfline] 2014-04-03 13:00:26 UTC
devack+

Comment 4 Ray Strode [halfline] 2014-06-23 00:00:24 UTC
i'm going to dupe this with bug 1069503 since they have the same root cause

*** This bug has been marked as a duplicate of bug 1069503 ***


Note You need to log in before you can comment on or make changes to this bug.