Bug 1069503 - gnome-session-properties does not save a job which is same as previously deleted
Summary: gnome-session-properties does not save a job which is same as previously deleted
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: gnome-session
Version: 6.6
Hardware: All
OS: All
unspecified
medium
Target Milestone: rc
: ---
Assignee: Ray Strode [halfline]
QA Contact: Desktop QE
URL:
Whiteboard:
: 1069499 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-25 07:22 UTC by Assen Totin
Modified: 2014-10-14 08:11 UTC (History)
1 user (show)

Fixed In Version: gnome-session-2.28.0-20.el6
Doc Type: Bug Fix
Doc Text:
refer to https://bugzilla.redhat.com/show_bug.cgi?id=785828 for CCFR
Clone Of:
Environment:
Last Closed: 2014-10-14 08:11:44 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1585 normal SHIPPED_LIVE gnome-session bug fix and enhancement update 2014-10-14 01:39:56 UTC

Description Assen Totin 2014-02-25 07:22:28 UTC
Description of problem:
gnome-session-properties does not save a start-up job which is same as previously deleted one.

Version-Release number of selected component (if applicable):
gnome-session-2.28.0-18

How reproducible:
Every time.

Steps to Reproduce:
1. Open gnome-session-properties. Create a new start-up job. Save it. Close gnome-session-properties. 
2. Re-open gnome-session-properties. Verify the job created at step 1 exists. Delete it. Close gnome-session-properties. 
3. Re-open gnome-session-properties. Verify the delete job is absent. Create a new one, identical to the deleted job. Save it. Verify the job is in the list of start-up jobs. Close gnome-session-properties
4. Re-open gnome-session-properties. The job created at step 3 is misisng fom the list.

Actual results:
A new job is not saved if it matches a previously deleted one.

Expected results:
A new job should always be saved.

Additional info:
It could be even worse: it seems the job does not even have to be identical to a delete one; if the command line is different, the job is still not saved. Likely the bug occurs even if only the name of the job matches a previously deleted one.

Comment 2 Ray Strode [halfline] 2014-04-03 12:59:30 UTC
i vaguely remember this bug getting fixed upstream, devack+, but still need to investigate.

Comment 3 Ray Strode [halfline] 2014-06-22 23:58:02 UTC
turns out this is just another case of bug 785828

Comment 4 Ray Strode [halfline] 2014-06-23 00:00:24 UTC
*** Bug 1069499 has been marked as a duplicate of this bug. ***

Comment 9 errata-xmlrpc 2014-10-14 08:11:44 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1585.html


Note You need to log in before you can comment on or make changes to this bug.