Bug 1128131 - Resource tree for EAP5 changes after upgrade to JON 3.3.0 DR01
Summary: Resource tree for EAP5 changes after upgrade to JON 3.3.0 DR01
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Operations Network
Classification: JBoss
Component: UI
Version: JON 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ER02
: JON 3.3.0
Assignee: Stefan Negrea
QA Contact: Mike Foley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-08-08 11:08 UTC by Jan Bednarik
Modified: 2014-09-21 22:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-22 13:55:15 UTC
Type: Bug


Attachments (Terms of Use)
EAP 5 resource tree before and after the upgrade (186.21 KB, image/png)
2014-08-08 11:08 UTC, Jan Bednarik
no flags Details
EAP 5 resource tree is the same after upgrade (139.54 KB, image/png)
2014-08-22 13:55 UTC, Jan Bednarik
no flags Details

Description Jan Bednarik 2014-08-08 11:08:43 UTC
Created attachment 925157 [details]
EAP 5 resource tree before and after the upgrade

Description of problem:
Resource tree of EAP 5 changes after upgrade from JON 3.2.0 GA to 3.3.0 DR01 (see attached screenshot).

Version-Release number of selected component (if applicable):
JON 3.3.0 DR01

How reproducible:
always

Steps to Reproduce:
1. Install JON 3.2.0 GA server and remote agent monitoring EAP 5
2. Using Web UI check the contents of EAP's reource tree (make the screenshot)
3. Upgrade JON server to version 3.3.0 and wait until the remote agent is upgraded as well.
4. Using Web UI check the contents of EAP's reource tree and compare it with the resource tree before the upgrade.

Actual results:
The resource tree has changed. More specifically, the 'Resource' subcategory is moved to the lower level and it holds different content.

Expected results:
The resource tree does not change.

Additional info:

Comment 1 Jan Bednarik 2014-08-08 11:11:18 UTC
See also BZ 1069545 which describes the JON3-8 Put EAP subsystems into JON subcategories requirement. Relevant TCMS test case can be found here: https://tcms.engineering.redhat.com/case/385013/?from_plan=14289

Comment 2 Jay Shaughnessy 2014-08-20 19:50:02 UTC
Stefan, this sounds like maybe when you updated the plugin descriptor for the subcategory changes, maybe something got tweaked?  Or maybe this is an intended change?

Comment 3 Stefan Negrea 2014-08-21 21:43:52 UTC
The result is a little suprising given the fact that the plugin upgrade should correctly set the nested resource subcategories. 

Here is what happens during the upgrade process:
1) JON server is upgraded which means that a simplistic db upgrade job runs to clean up the existing tables from the database.
2) Afterwards, the EAP 5 plugin upgrade will correctly set the nested subcategories. 


The steps from the description are not very clear about the actual plugin upgrade. I will need to check with the author to ensure the testing followed the proper upgrade procedure.

Comment 4 Jan Bednarik 2014-08-22 13:55:15 UTC
I retested this issue again, I upgraded JON server 3.2.0 GA -> 3.3.0 DR01, gave remote agent monitoring EAP 5 enough time to download/install new plugins, and the  issue did not occur again. The reason must be last time I did not explicitly check the remote agent installed new plugins and did not give it enough time. After discussion with Stefan I am closing this BZ as NOTABUG.

See attached screenshot.

Comment 5 Jan Bednarik 2014-08-22 13:55:47 UTC
Created attachment 929657 [details]
EAP 5 resource tree is the same after upgrade


Note You need to log in before you can comment on or make changes to this bug.