Bug 106966 - Crashes during Install if you select Upgrade
Crashes during Install if you select Upgrade
Status: CLOSED DUPLICATE of bug 106965
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 21:37 EDT by John Slater
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:59:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Slater 2003-10-13 21:37:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When upgrading from test2 to test3, selecting Upgrade crashes shortly after the
searching for components to upgrade splash appears.

Version-Release number of selected component (if applicable):
test3

How reproducible:
Always

Steps to Reproduce:
1.Select Upgrade System
2.
3.
    

Actual Results:  Crashes when searching for packages to install.

Expected Results:  no crash

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x9cd1fc4>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.
py'>
instPath: /mnt/sysimage
package: <rpm.hdr object at 0x98d5f28>
h: <rpm.hdr object at 0xbcd6508>
mi: <rpm.mi object at 0xa62c0f8>
ts: <rpm.ts object at 0xbcca298>
method: <image.CdromInstallMethod instance at 0x9718bbc>
myarch: i386
currentVersion: 0.94
hasX: 1
file: __db.003
supportedUpgradeVersion: -1
release: fr1
found: 0
packages: [<rpm.hdr object at 0x9910770>, <rpm.hdr object at 0xa1010a0>, <rpm.hd
r object at 0x9fcd5d8>, <rpm.hdr object at 0x9ee3558>, <rpm.hdr object at 0xa08b
6c8>, <rpm.hdr object at 0xa0f3d70>, <rpm.hdr object at 0xa298630>, <rpm.hdr
objTraceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x9cd1fc4>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.py'>
instPath: /mnt/sysimage
Comment 1 Bill Nottingham 2003-10-14 01:01:46 EDT

*** This bug has been marked as a duplicate of 106965 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:59:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.