This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 106965 - Crashes during Install if you select Upgrade
Crashes during Install if you select Upgrade
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
: 106966 107017 107092 107124 107178 107182 107304 107334 107377 107406 107480 107485 107950 108058 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-13 21:29 EDT by John Slater
Modified: 2007-11-30 17:10 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-02 14:49:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anacdump.txt from GUI upgrade exeception error (586.91 KB, text/plain)
2003-10-14 02:07 EDT, Jussi Torhonen
no flags Details
anacdump.txt from TUI upgrade exeception error (587.08 KB, text/plain)
2003-10-14 02:08 EDT, Jussi Torhonen
no flags Details

  None (edit)
Description John Slater 2003-10-13 21:29:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
When upgrading from test2 to test3, selecting Upgrade crashes shortly after the
searching for components to upgrade splash appears.

Version-Release number of selected component (if applicable):
test3

How reproducible:
Always

Steps to Reproduce:
1.Select Upgrade System
2.
3.
    

Actual Results:  Crashes when searching for packages to install.

Expected Results:  no crash

Additional info:

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x9cd1fc4>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.
py'>
instPath: /mnt/sysimage
package: <rpm.hdr object at 0x98d5f28>
h: <rpm.hdr object at 0xbcd6508>
mi: <rpm.mi object at 0xa62c0f8>
ts: <rpm.ts object at 0xbcca298>
method: <image.CdromInstallMethod instance at 0x9718bbc>
myarch: i386
currentVersion: 0.94
hasX: 1
file: __db.003
supportedUpgradeVersion: -1
release: fr1
found: 0
packages: [<rpm.hdr object at 0x9910770>, <rpm.hdr object at 0xa1010a0>, <rpm.hd
r object at 0x9fcd5d8>, <rpm.hdr object at 0x9ee3558>, <rpm.hdr object at 0xa08b
6c8>, <rpm.hdr object at 0xa0f3d70>, <rpm.hdr object at 0xa298630>, <rpm.hdr
objTraceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 530, in upgradeFindPackages
    (h[rpm.RPMTAG_EPOCH], h[rpm.RPMTAG_VERSION],
TypeError: argument 2, item 0 must be string or None, not int

Local variables in innermost frame:
intf: <gui.InstallInterface instance at 0x9cd1fc4>
hasFileManager: 1
vers: 0.94
findpackageset: <module 'findpackageset' from '/usr/lib/anaconda/findpackageset.py'>
instPath: /mnt/sysimage
Comment 1 Bill Nottingham 2003-10-14 01:01:49 EDT
*** Bug 106966 has been marked as a duplicate of this bug. ***
Comment 2 Sean Earp 2003-10-14 01:14:22 EDT
I also have a crash when choosing upgrade, at the same point as described above.
 My two differences are as follows:

1) I am upgrading from RH9 instead of Fedora Cora test 2
2) I have a different crash error message: (I can attach the crash log if it
will help).  

I recieve the same error message installing from the ISOs, or doing  an ftp
install from a separately downloaded boot.iso

Traceback (most recent call last):
  File "/usr/lib/anaconda/gui.py", line 766, in nextClicked
    self.dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py", line 168, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 236, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 338, in upgradeFindPackages
    method.mergeFullHeaders(id.grpset.hdrlist)
  File "/usr/lib/anaconda/urlinstall.py", line 217, in mergeFullHeaders
    fn = self.getFilename("RedHat/base/hdlist2", callback=None)
  File "/usr/lib/anaconda/urlinstall.py", line 117, in getFilename
    log("IOError %s occurred getting %s: %s"
  File "/usr/lib/python2.2/site-packages/rhpl/log.py", line 47, in __call__
    self.handler (format % args)
TypeError: not enough arguments for format string
Comment 3 Jussi Torhonen 2003-10-14 02:06:06 EDT
I got the same error when trying to upgrade Fedora test2 0.94 upto test3 0.95.
It was the same Exception Occured even running GUI or TUI installer. I made
those anacdump.txt diskettes. I'll attach both GUI and TUI logs here.
Comment 4 Jussi Torhonen 2003-10-14 02:07:41 EDT
Created attachment 95154 [details]
anacdump.txt from GUI upgrade exeception error
Comment 5 Jussi Torhonen 2003-10-14 02:08:26 EDT
Created attachment 95155 [details]
anacdump.txt from TUI upgrade exeception error
Comment 6 Petr Suchomel 2003-10-14 07:37:53 EDT
I have exactly the same problem, stack trace is the same.
Comment 7 Jeremy Katz 2003-10-14 11:18:28 EDT
Fixed in CVS, update disk at http://people.redhat.com/~katzj/severn-t3-updates.img
Comment 8 Bill Nottingham 2003-10-14 11:33:46 EDT
*** Bug 107017 has been marked as a duplicate of this bug. ***
Comment 9 Petr Suchomel 2003-10-14 16:20:57 EDT
Are you going to update ISO image for disc 1, or how to patch this disk? I never
did that. Thanks.
Comment 10 Jeremy Katz 2003-10-14 16:25:03 EDT
http://rhlinux.redhat.com/anaconda/updatedisks.html has instructions on using an
update disk
Comment 11 Jeremy Katz 2003-10-14 19:47:13 EDT
*** Bug 107092 has been marked as a duplicate of this bug. ***
Comment 12 Jussi Torhonen 2003-10-15 06:53:49 EDT
severn-t3-updates.img helped for me. Tnx.

Jussi
Comment 13 Jeremy Katz 2003-10-15 12:40:36 EDT
*** Bug 107124 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2003-10-15 14:13:33 EDT
*** Bug 107182 has been marked as a duplicate of this bug. ***
Comment 15 Jeremy Katz 2003-10-15 14:14:28 EDT
*** Bug 107178 has been marked as a duplicate of this bug. ***
Comment 16 Bob Lynch 2003-10-15 14:58:51 EDT
Using the severn-t3-updates.img, URL above, still have problems:

Running Anaconda
Traceback (most recent call last):
File "/usr/bin/anaconda", line 344, in ?
   input dispatch
File "/usr/lib/anaconda", dispatch.py, line 36, in ?    
   from upgrade input upgradeFindPackages, upgradeMountFilesystems
File "/tmp/updates", upgrade.py, line 371
  ^
Syntax error: invalid syntax

The install bombs again.  Sorry if there are minor errors in the above, I had to
write it down then retype it.
Comment 17 Bob Lynch 2003-10-15 16:06:54 EDT
Addendum to Additional Comment #16, above: playing around with the update
referenced above, I found either the downloaded image or floppy disk mde from it
was faulty.  Redoing this led to upgrade going fine.  Resolved.
Comment 18 Michael Koziarski 2003-10-15 23:53:11 EDT
Perhaps this update should be mentioned on the fedora.redhat.com site?

Most if not all of the users will be upgrading from a previous release and this
defect will no doubt be reporting continuously.
Comment 19 Jeremy Katz 2003-10-16 14:07:40 EDT
*** Bug 107304 has been marked as a duplicate of this bug. ***
Comment 20 Bill Nottingham 2003-10-16 21:35:02 EDT
*** Bug 107334 has been marked as a duplicate of this bug. ***
Comment 21 Jeremy Katz 2003-10-17 13:05:16 EDT
*** Bug 107377 has been marked as a duplicate of this bug. ***
Comment 22 Jeremy Katz 2003-10-17 16:34:15 EDT
*** Bug 107406 has been marked as a duplicate of this bug. ***
Comment 23 Horst H. von Brand 2003-10-18 09:19:57 EDT
I see the same basic problem:

- Upgrade from RH 9 works
- Upgrade from RH 10 beta1 works
- Upgrade from FC 1 test2 crashes (GUI and TUI; booting from floppy or CD)
Comment 24 Jeremy Katz 2003-10-18 23:11:55 EDT
*** Bug 107480 has been marked as a duplicate of this bug. ***
Comment 25 Rich Mitchell 2003-10-19 22:25:31 EDT
.img solution doesn't work for me as my system does not have a floppy.  Please 
give me an idea as to how to proceed.
Comment 26 Jeremy Katz 2003-10-19 22:26:03 EDT
*** Bug 107485 has been marked as a duplicate of this bug. ***
Comment 27 Jeremy Katz 2003-10-24 16:56:05 EDT
*** Bug 107950 has been marked as a duplicate of this bug. ***
Comment 28 Jeremy Katz 2003-10-27 09:57:56 EST
*** Bug 108058 has been marked as a duplicate of this bug. ***
Comment 29 Michael Koziarski 2004-03-10 21:05:17 EST
This should be closed right?  
Comment 30 Dale Marchand 2004-08-13 21:31:33 EDT
I have a similar problem when upgrading from Fedora Core 2 to Fedora 
Core 3 Test 1.  Here's the output:

Traceback (most recent call last):
  File "/usr/bin/anaconda", line 1145, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/lib/anaconda/text.py", line
486, in run
    dispatch.gotoNext()
  File "/usr/lib/anaconda/dispatch.py",
line 169, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py",
line 237, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/packages.py",
line 737, in doPreInstall
    os.mkdir(instPath + "/selinux")
OSError: [Errno 17] File exists:
'/mnt/sysimage/selinux'
Comment 31 Benjamin Baez 2004-08-15 00:20:35 EDT
Hello,

The problem I had was that an old version of linuxconf was partially
installed/uninstalled.  A 'rpm -e ..' didn't work because it
complained about a script error (I did this in Dec. 2003 and forgot to
take notes), so I upgraded to the latest version of linuxconf (rpm
-Uvh) then uninstalled it.  The installation of Fedora Core 1 then
completed correctly.  Same method worked on a similar system with the
same problem.
Comment 32 David Lawrence 2004-09-02 14:47:41 EDT
OSError: [Errno 17] File exists: '/mnt/sysimage/selinux' still present
in fc3test1.
Comment 33 Jeremy Katz 2004-09-02 14:49:27 EDT
dkl, that's a completely different bug (bug #127713)

Note You need to log in before you can comment on or make changes to this bug.