Bug 106985 - Fix gaim system tray icon for one pixel issue
Summary: Fix gaim system tray icon for one pixel issue
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-14 06:43 UTC by louisgtwo
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-21 13:34:45 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
When tray icon is bad (438.95 KB, image/png)
2003-10-14 18:58 UTC, louisgtwo
no flags Details
When tray icon is good (436.19 KB, image/png)
2003-10-14 19:00 UTC, louisgtwo
no flags Details
the fixed eggtrayicon module C (12.53 KB, text/plain)
2003-10-17 08:39 UTC, Daniel Veillard
no flags Details
the associated header for the module (2.47 KB, text/plain)
2003-10-17 08:40 UTC, Daniel Veillard
no flags Details

Description louisgtwo 2003-10-14 06:43:17 UTC
I believe gtk+ has a bug which causes notification area icons to be one pixel
wide when under load. the rhn-applet just fixed this issue and wondering if gaim
could incorporate that fix also.

I use gaim's system tray icon so when I log in and out gaim logs in
automatically. Fairly often the tray icon is only one pixel wide when loging in.

Comment 1 Christopher Blizzard 2003-10-14 17:43:57 UTC
Do you have a patch?  I've never seen this happen.

Comment 2 louisgtwo 2003-10-14 18:58:47 UTC
Created attachment 95171 [details]
When tray icon is bad

Comment 3 louisgtwo 2003-10-14 19:00:15 UTC
Created attachment 95172 [details]
When tray icon is good

Comment 4 Christopher Blizzard 2003-10-16 17:04:15 UTC
Still can't reproduce here.  Tried loading and unloading the plugin multiple times.

Comment 5 louisgtwo 2003-10-16 18:21:16 UTC
I don't think you can produce the bug that way. It only happens right after
login. Leave gaim and the plugin running. Log out and save session. When login
back in gaim should be running. This is when the plugin gets messed up. If you
can contact Daniel Veillard <veillard@redhat.com> he fixed the same problem in
rhn-applet.


Comment 6 Christopher Blizzard 2003-10-17 01:25:39 UTC
DV, any ideas?

Comment 7 Daniel Veillard 2003-10-17 08:39:46 UTC
Created attachment 95258 [details]
the fixed eggtrayicon module C

Comment 8 Daniel Veillard 2003-10-17 08:40:37 UTC
Created attachment 95259 [details]
the associated header for the module

Comment 9 Daniel Veillard 2003-10-17 08:45:55 UTC
The eggtrayicon.[ch] is not part of the GNOME libraries APIs, it's
copied in all client code. This is a maintainance nightmare, blame
Havoc :-) !
To fix the problem I updated the module to the latest version from
the libegg CVS and applied a patch from Owen when he managed to
reproduce and debug the problem.
The new versions of the module are attached, hopefully you can generate
a simple patch from the existing version of eggtrayicon.[ch] from
Gaim. Then push it back upstream, I dunno if Owen fixed it in libegg
CVS ...
                                                                                
Daniel


Comment 10 Christopher Blizzard 2003-10-17 16:56:25 UTC
I dropped this file into a build if people want to test:

http://people.redhat.com/blizzard/software/gaim/0.71-1/

let me know if you find any problems.  The patch didn't seem too scary, except
for some DV-specific stuff at the top. :)

Comment 11 Christopher Blizzard 2003-10-21 13:34:45 UTC
This is in the tree now, so I'm hoping it's fixed.


Note You need to log in before you can comment on or make changes to this bug.