Bug 106994 - translated menu is missing in XEmacs
Summary: translated menu is missing in XEmacs
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: xemacs-sumo (Show other bugs)
(Show other bugs)
Version: 1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 111781
Blocks: CambridgeTarget
TreeView+ depends on / blocked
 
Reported: 2003-10-14 10:42 UTC by Nakai
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-09 00:59:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nakai 2003-10-14 10:42:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
XEmacs menu is English in Fedore core.
(Cambridge-re1013.nightly)

There was Japanese, French or other translated menu in
xemacs on Red Hat Linux 9.
This is anti-improvements for upper version and
English is bug in Japan.

Version-Release number of selected component (if applicable):
xemacs-21.4.14-1

How reproducible:
Always

Steps to Reproduce:
1. Run XEmacs in LANG=ja_JP.UTF-8 or ja_JP.eucJP environment.
2. See menu
3. English.
    

Actual Results:  English

Expected Results:  Japanese

Additional info:

Comment 1 Jens Petersen 2003-10-15 11:37:47 UTC
Yes, I'm afraid I don't know of an easy to fix this, since the toolkit
used for the XEmacs menubar doesn't support utf-8 encoding afaik.
So until xemacs moves to a modern toolkit I don't there is anyway to
deal with this.

(If one tries to start the xemacs in RHL 9 in ja_JP.UTF-8 locale, a spew
of X warnings appear and the X window never materializes on the screen...)

Comment 2 Nakai 2003-10-15 17:07:09 UTC
I don't think so, because XEmacs menus doesn't recognize EUC-JP. It just
depends on libc/X locale system. So, with an appropriate font specify and
UTF-8 converted resources, it should works with ja_JP.UTF-8.

I understand your priority for this issue is not so high for this product.

Comment 3 Jens Petersen 2003-10-17 13:03:02 UTC
Ok, I guess you're right.  However I'm not sure if we have a good unicode
font to cover this?

Comment 4 Jens Petersen 2003-10-17 13:17:13 UTC
I'm re-enabling menu translations for native CJK encodings in
xemacs-sumo-20031003-2 and xemacs-21.4.14-2.

Comment 5 Nakai 2003-10-20 06:01:29 UTC
Fonts in 

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=81717

will help you

Comment 6 Jens Petersen 2003-12-09 00:59:13 UTC
I'm afraid I think it is a bit much to add fonts just to
get the menubar to appear in ja, so I would like to close
this for now.  From upstream's point of view, core XEmacs
doesn't even have utf-8 support, so a menubar for utf-8
is probably not a high priority either I'm afraid.

Comment 7 Jens Petersen 2003-12-09 04:23:57 UTC
If we get a unicode font included in the distro, then it
should be possible to fix this problem.


Note You need to log in before you can comment on or make changes to this bug.