Bug 107022 - elinks segfaults, and is generally unstable
elinks segfaults, and is generally unstable
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: elinks (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-10-14 10:09 EDT by Bill Nottingham
Modified: 2014-03-16 22:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.4.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-12-08 08:40:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test file (87 bytes, text/html)
2003-10-14 10:49 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2003-10-14 10:09:15 EDT
In general browsing with elinks, it
a) segfaults
b) hangs doing DNS lookups

Here's a backtrace of the segfault (from the core file; when run under gdb DNS
lookups just don't work):

(gdb) bt
#0  0x0078e2bc in _int_free () from /lib/tls/libc.so.6
#1  0x0078d28b in free () from /lib/tls/libc.so.6
#2  0x08072a58 in free_connection_data (c=0x8527d8) at sched.c:352
#3  0x08073228 in retry_connection (c=0x8187158) at sched.c:560
#4  0x08078a5e in dns_found (data=0x8187158, state=-1) at connect.c:271
#5  0x080702aa in end_dns_lookup (q=0x81a1648, res=-1) at dns.c:371
#6  0x0806fe81 in end_real_lookup (data=0x81a1648) at dns.c:223
#7  0x0807527b in select_loop (init=0x804ace0 <init>) at select.c:488
#8  0x0804b1dd in main (argc=72, argv=0x1cac1) at main.c:455
(gdb)
Comment 1 Tim Waugh 2003-10-14 10:44:41 EDT
Any particular page that causes this?
Comment 2 Bill Nottingham 2003-10-14 10:49:50 EDT
Created attachment 95162 [details]
test file

Save this, load it with links ./foo.html, and hit enter on the link. It hangs
for me, but only when running links under gnome-terminal (works fine from the
console.)
Comment 3 Tim Waugh 2003-10-14 11:18:22 EDT
Works for me. :-/
Comment 4 Chris Ricker 2003-10-14 12:58:27 EDT
In an xterm, it works

In gnome-terminal, it hangs forever on the DNS query

If I strace it in gnome-terminal, the DNS query works
Comment 5 Barry K. Nathan 2003-10-21 21:27:22 EDT
I'm seeing segfaults too. On two different computers I saw it segfault when I
tried "links http://ftp.redhat.com/pub/redhat/linux/rawhide/i386/RedHat/RPMS/"
in gnome-terminal, as my first links invocation after a fresh install. This
segfault did not happen on any links invocations after the first one after a
fresh install (of test2 on one system, test3 on the other).

I guess this isn't enough info to help, but I'm mentioning all this just in case
it is...
Comment 6 Carlos Rodrigues 2003-11-30 11:41:13 EST
I'm also seeing elinks hanging on DNS lookups within gnome-terminal,
but in Fedora Core 1.
Comment 7 Jonathan Marc Bearak 2003-12-06 20:36:06 EST
I've had this problem with elinks regardless of running it in
gnome-terminal, xterm, or console.  I just noticed that on 11/25
Elinks 0.4.3 was released.  I compiled it, and am no longer having any
problems.

Note You need to log in before you can comment on or make changes to this bug.